Benchmarking...

Discussion in 'Install/Configuration' started by hopfi2k, Jun 5, 2004.

  1. hopfi2k

    hopfi2k New Member

    Hi there,

    I'm running LiteSpeed V1.5RC4 under FreeBSD 5.2.1 with a fresh compiled PHP 4.3.7 (using params as in FAQ).

    When I run ab -c 10 -1000 http://<servername>/phpinfo.php it won't finish the test! Somewhere after 4000 to 5000 request it stops with error message (apr_recv: Connection reset by peer (54)) and top shows 10 running php processes...

    Running the same benchmark with apache2 doesn't cause any problems...

    Trying to run ab with 100 concurrent connections doesn't work at all...

    Maybe I didn't configured the server correctly (well, to be honest, I'm using the default confiuration...)?
  2. mistwang

    mistwang LiteSpeed Staff

    Can you please try your test with the pre-built php binary?
    There might be some problems with PHP 4.3.7.

    And there is a per IP connection limits in lsws, the default is 10, so when you try to make 100 concurrent connections, lsws think some one is trying to attack the web site and close those connections immediately.

    Please increase both hard and soft connection limit under "Server"->"Security" page.

    Best regards.
  3. hopfi2k

    hopfi2k New Member

    Increasing hard and soft connection limit did the trick!

    Many thanks.

    The first results of my benchmarks show, that litespeed V1.5RC4 outperforms Apache 2.0 (worker mpm) by 1.5 - 4 times using php scripts!

    Not to forget the time one saves with Litespeeds easy configuration.

    Great!

    Best Regards

Share This Page