Bug in install script

Discussion in 'Bug Reports' started by bovinger, Sep 2, 2005.

  1. bovinger

    bovinger New Member

    Hello

    Version lsws2.1RC3 produce an error message when choosing eaccelerator:
    "missing ] in script". in line 191 in lsws2.1RC3/admin/misc/enable_ppa.sh

    elif [ $SEL -eq 3]; then //missing space after 3
    enablecache eaccelerator

    Should have been:

    elif [ $SEL -eq 3 ]; then
    enablecache eaccelerator
  2. mistwang

    mistwang LiteSpeed Staff

    Thank you for the bug report and the fix.
    We will update RC3 package.

    George Wang
  3. bovinger

    bovinger New Member

    I plan to use litespeed with a dell PowerEdge 6650 that use 4 X Xeon MP.

    Does your webserver support hyper-threading ?
  4. mistwang

    mistwang LiteSpeed Staff

    Yes, our Enterprise edition can take advantage of SMP server by lshttpd itself.
    Enterprise edition actually is licensed by number of worker processes, not by number of cpu sockets. So LSWS with any number of CPU license can be used on your server, unused CPU will be available to PHP and DB Server.

    According to our study, hyper-threading may or may not help with performance at all, you may want to do some performance test with your web application.

Share This Page