cli has eaccelerator, litespeed doesn't

Discussion in 'PHP' started by alexr, Feb 24, 2009.

  1. alexr

    alexr New Member

    I have tried a bunch of times to get eaccelerator to get built by litespeed using the WHM plugin. For some reason after the easyapache script builds the PHP with eaccelerator litespeed is not sensing it. If I run php-v it has the eaccelerator loaded, but if I do that on the fcgi litespeed version the eaccelerator part isn't there. Any ideas?

    Thanks!
  2. mistwang

    mistwang LiteSpeed Staff

    Make sure the same php.ini is used by cli and lsphp5
  3. alexr

    alexr New Member

    I guess I could be more clear:
    /usr/local/bin/php -v returns
    Code:
    PHP 5.2.8 (cli) (built: Feb 23 2009 22:13:43)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
        with eAccelerator v0.9.5.3, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
        with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
        with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
        with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies
    /opt/lsws/fcgi-bin/lsphp5 -v returns:
    Code:
    PHP 5.2.8 (litespeed) (built: Feb 16 2009 22:32:32)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
        with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
        with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
        with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies
    
    Yet when I try to build matching I get:
    Found Apache php binary at /usr/local/bin/php. Version is 5.2.8

    Found LiteSpeed php binary at /opt/lsws/fcgi-bin/lsphp5. Version is 5.2.8

    Configuration options for LiteSpeed php and Apache php are matched.

    No action needed for PHP version 5.2.8
  4. mistwang

    mistwang LiteSpeed Staff

    check the php.ini path in output of "php -i"
  5. alexr

    alexr New Member

    php --ini
    Code:
    Configuration File (php.ini) Path: /usr/local/lib
    Loaded Configuration File:         /usr/local/lib/php.ini
    Scan for additional .ini files in: (none)
    Additional .ini files parsed:      (none)
    
  6. Tony

    Tony Member

    My guess is it's an issue with the eaccelerator loader. I've found the majority of the time the build matching php binary it'll be unable to load the modules built by easy apache. The error that is probably being produced is about matching symbols on the eaccelerator module (I think that's the error). You will not see the error on pages as it's a suppressed one although it might appear in the error_log if php is writing one to folder the php script ran from.

    What I've done is when I build the matching php the first time I also take the modules folder files (pdo, pdo_mysql ect.) and put those into the php extension folder. I also then grab the cli files built and overwrite the existing ones. Then things like eaccelerator I can build manually. Then the lsphp and cli php are both compatible with each other no errors on either end.

    I have absolutely no idea why this happens but this is my experience with that. A few cases it did work fine other cases it did not and I have no idea why.
  7. mistwang

    mistwang LiteSpeed Staff

    Like Tony said, there might be compatibility issues with PHP modules. If there is a problem, you will see some error/warning messages when you run

    lsws/fcgi-bin/lsphp5 -i
  8. alexr

    alexr New Member

    I guess I will just get the config options and build PHP from the Litespeed panel with eaccelerator selected in there, everything else seems to be working.

    Thanks!
  9. alexr

    alexr New Member

    I tried that idea with no luck, I then looked through the whole output of the lsws/fcgi-bin/lsphp5 -i, there are no errors and not even a mention of eaccelerator...
  10. mistwang

    mistwang LiteSpeed Staff

    does it show that /usr/local/lib/php.ini is being used?
  11. alexr

    alexr New Member

    Figured it out, it was pointing to the /usr/local extensions as well, changed it to the /opt/lsws extensions for zts and now it is working great. Didn't think about that, yes it is using that php.ini because that is the prefix I set.

    Thanks!

Share This Page