Cpanel + awstats: problems with permissions

Discussion in 'General' started by fernandomm, Apr 23, 2012.

  1. fernandomm

    fernandomm New Member

    Hi,

    I noticed that after installing Litespeed, Awstats stops working on Cpanel servers.

    This happens because it can't write on logs anymore. After changing the permissions to nobody:username, it works normally.

    My question is: how do i fix this permanently and for all users? Any script that i should use?

    Thanks.
    Last edited: Apr 23, 2012
  2. consultorpc

    consultorpc New Member

    Hello, we have also this problem, we are a paid customer (ESB83964601), can someone of staff give us some support about this ? Kind regards.
  3. webizen

    webizen New Member

    how about change logs owership to username.nobody and permission being group writeable?
  4. fernandomm

    fernandomm New Member

    The problem is that at some point it changes back the ownership and permissions. This seems to happen only when running Litespeed. With Apache, the permissions/ownership are not touched at all.
  5. muiruri

    muiruri Member

    We're having the same problem also, awstats stopped working this past weekend on Saturday the 21st.

    After cpanel tech-support checked also found at; /usr/local/apache/domlogs/

    owner permissions had been changed by Litespeed to nobody.nobody

    When we switch to Apache, they wrote a script to restore permissions to root.username

    But when we switch back to Litespeed, in less than 16 secs, it changes permissions again back to nobody.nobody and that makes the logs files not writable.

    For some strange reason, we have Litespeed on other servers and this problem is not there, plus on this server all has been fine with Litepseed for last 2 years and no such issue, therefore puzzle now is what happened to Litespeed this past weekend to start changing permissions to nobody.nobody for logs files at; /usr/local/apache/domlogs

    Any ideas? Any help?
  6. webizen

    webizen New Member

    what's your LSWS version?
  7. muiruri

    muiruri Member

    Yes, forgot to mention our LSWS version is 4.1.11
    Last edited: Apr 26, 2012
  8. NiteWave

    NiteWave Administrator

Share This Page