Disabling useless logging in error_log?

Discussion in 'General' started by optize, Mar 14, 2010.

  1. optize

    optize New Member

    By default, this gets added to error_log;

    2010-03-13 22:19:16.099 [INFO] [HTAccess] Updating configuration from [/home/shopheav/public_html/.htaccess]
    2010-03-13 22:19:16.274 [INFO] Remove pid: 5653
    2010-03-13 22:19:16.274 [INFO] Pid: 5653 associated with [APVH_vchacha_Suphp:]
    2010-03-13 22:19:16.274 [INFO] ProcInfo Pid: 5653, socket: /tmp/lshttpd/APVH_guidetoros.com_Suphp.sock.631
    2010-03-13 22:19:16.274 [INFO] [APVH_vchacha_Suphp:] pid list size: 0, pid stop list size: 0
    2010-03-13 22:19:17.026 [NOTICE] [APVH_vchacha_Suphp:] stop worker processes
    2010-03-13 22:19:17.686 [INFO] [HTAccess] Updating configuration from [/home/onlineac/www.2ing.com/.htaccess]
    2010-03-13 22:19:17.722 [INFO] Start listen socket [/tmp/lshttpd/APVH_onlineer.com_Suphp.sock].
    2010-03-13 22:19:17.725 [INFO] [APVH_onlineac_Suphp:] pid list size: 1
    2010-03-13 22:19:17.725 [INFO] [APVH_onlineac_Suphp:] add child process pid: 5776
    2010-03-13 22:19:18.571 [INFO] [HTAccess] Updating configuration from [/home/niivedco/public_html/.htaccess]
    2010-03-13 22:19:18.571 [INFO] Start listen socket [/tmp/lshttpd/APVH_niived.com_Suphp.sock].
    2010-03-13 22:19:18.574 [INFO] [APVH_niivedco_Suphp:] pid list size: 1
    2010-03-13 22:19:18.574 [INFO] [APVH_niivedco_Suphp:] add child process pid: 5779
    2010-03-13 22:19:18.643 [INFO] Remove pid: 5757
    2010-03-13 22:19:18.643 [INFO] Pid: 5757 associated with [APVH_internet_Suphp:]
    2010-03-13 22:19:18.643 [INFO] ProcInfo Pid: 5757, socket: /tmp/lshttpd/APVH_internetmair.com_Suphp.sock.870
    2010-03-13 22:19:18.643 [INFO] [APVH_internet_Suphp:] pid list size: 0, pid stop list size: 0
    2010-03-13 22:19:18.813 [INFO] Start listen socket [/tmp/lshttpd/APVH_ned.com_Suphp.sock.394].
    2010-03-13 22:19:18.816 [INFO] [APVH_niivedco_Suphp:] pid list size: 2
    2010-03-13 22:19:18.816 [INFO] [APVH_niivedco_Suphp:] add child process pid: 5780
    2010-03-13 22:19:19.073 [NOTICE] [APVH_internet_Suphp:] stop worker processes

    I don't see a good reason to have it. Is there a way to disable it and only show important logging in error_log so I don't have to dig through 50 gigs of logs to find something?
  2. optize

    optize New Member

    I found out how to turn off INFO messages, which seemed to be most of it.

    My error_log is now:

    2010-03-13 22:22:57.128 [NOTICE] [APVH_iloveops_Suphp:] stop worker processes
    2010-03-13 22:22:57.128 [NOTICE] [APVH_tpforums_Suphp:] stop worker processes
    2010-03-13 22:22:57.128 [NOTICE] [APVH_jonbreen_Suphp:] stop worker processes
    2010-03-13 22:22:57.128 [NOTICE] [APVH_veinasia_Suphp:] stop worker processes
    2010-03-13 22:22:57.278 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets belong to process 4348 !
    2010-03-13 22:22:57.278 [INFO] [CLEANUP] Clean up child process with pid: 5412
    2010-03-13 22:22:57.379 [NOTICE] [AutoRestarter] child process with pid=4348 exited with status=0!
    2010-03-13 22:22:57.379 [NOTICE] [PID:3725] Server Stopped!
    2010-03-13 22:22:58.022 [NOTICE] [APVH_xhotfile_Suphp:] stop worker processes
    2010-03-13 22:23:00.012 [NOTICE] [APVH_tpforums_Suphp:] stop worker processes
    2010-03-13 22:23:02.011 [NOTICE] [APVH_sttwokor_Suphp:] stop worker processes
    2010-03-13 22:23:02.011 [NOTICE] [APVH_detektei_Suphp:] stop worker processes
    2010-03-13 22:23:05.561 [ERROR] [HTAccess] Failed to open [/home/pmudcom/public_html/cms/loanofficer/sites/all/modules/.htaccess]: Permission denied
    2010-03-13 22:23:10.139 [ERROR] [HTAccess] Failed to open [/home/pmudcom/public_html/cms/loanofficer/sites/all/modules/.htaccess]: Permission denied
    2010-03-13 22:23:11.010 [NOTICE] [APVH_jocurine_Suphp:] stop worker processes
    2010-03-13 22:23:13.009 [NOTICE] [APVH_garbages_Suphp:] stop worker processes
    2010-03-13 22:23:14.054 [NOTICE] [APVH_iloveops_Suphp:] stop worker processes
    2010-03-13 22:23:15.034 [NOTICE] [APVH_modernro_Suphp:] stop worker processes


    Some of that seems important (permission denied, etc) however for every real error message I have 50 stop worker procseses error messages.

    Is there a way to not log those?

Share This Page