Error 503 on Opensolaris

Discussion in 'PHP' started by andreas, Jun 27, 2009.

  1. andreas

    andreas New Member

    Hi,

    I have built PHP 5.2.9 on LSWS 4.0.5. But it doesn't work with the config from the DEFAULT host, I get 503s. Debug log:
    Code:
    2009-06-27 22:57:37.922 [DEBUG] [x.x.x.x:61413-1#Example] Find context with URI: [/], location: [/opt/lsws/DEFAULT/html/]
    2009-06-27 22:57:37.922 [DEBUG] [x.x.x.x:61413-1#Example] Find handler [lsphp5] for [.php]
    2009-06-27 22:57:37.922 [DEBUG] [x.x.x.x:61413-1#Example] processContextPath() return 0
    2009-06-27 22:57:37.922 [DEBUG] [x.x.x.x:61413-1#Example] run lsapi processor.
    2009-06-27 22:57:37.923 [INFO] [lsphp5] add child process pid: 26674
    2009-06-27 22:57:37.923 [INFO] [lsphp5] pid list size: 1 
    2009-06-27 22:57:37.923 [DEBUG] [uds://tmp/lshttpd/lsphp5.sock] create new connection succeed!
    2009-06-27 22:57:37.923 [DEBUG] [uds://tmp/lshttpd/lsphp5.sock] request [x.x.x.x:61413-1#Example:lsapi] is assigned with connection!
    2009-06-27 22:57:37.923 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] [ExtConn] reconnect()
    2009-06-27 22:57:37.923 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] [ExtConn] connecting to [uds://tmp/lshttpd/lsphp5.sock]...
    2009-06-27 22:57:37.923 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] ExtConn::onWrite()
    2009-06-27 22:57:37.923 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] request header is done
    2009-06-27 22:57:37.923 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] ExtConn::continueRead()
    2009-06-27 22:57:37.923 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] Request body done!
    2009-06-27 22:57:37.923 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] ExtConn::suspendWrite()
    2009-06-27 22:57:37.923 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] processNewReq() return 0. 
    2009-06-27 22:57:37.935 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] ExtConn::onRead()
    2009-06-27 22:57:37.935 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] LsapiConn::doRead()
    2009-06-27 22:57:37.935 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] process packet header -1 bytes
    2009-06-27 22:57:37.935 [INFO] [x.x.x.x:61413-1#Example:lsapi] connection to [uds://tmp/lshttpd/lsphp5.sock] on request #0, confirmed: 0, Connection reset by peer!
    2009-06-27 22:57:37.935 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] [ExtConn] close()
    2009-06-27 22:57:37.935 [DEBUG] [uds://tmp/lshttpd/lsphp5.sock] No Request has been processed successfully through this connection, the maximum connections allowed will be reduced!
    ...
    2009-06-27 22:57:37.936 [NOTICE] [x.x.x.x:61413-1#Example:lsapi] Max retries has been reached, 503!
    2009-06-27 22:57:37.936 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] HttpIOLink::continueWrite()...
    2009-06-27 22:57:37.936 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] write resumed!
    2009-06-27 22:57:37.936 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] HttpIOLink::handleEvents() events=4!
    2009-06-27 22:57:37.936 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] HttpIOLink::suspendWrite()...
    2009-06-27 22:57:37.936 [DEBUG] [x.x.x.x:61413-1#Example:lsapi] HttpConnection::sendHttpError(),code=503 Service Unavailable
    2009-06-27 22:57:37.936 [NOTICE] [x.x.x.x:61413-1#Example:lsapi] oops! 503 Service Unavailable
    
    Running lsphp5 in the console as the webserver user works fine.
  2. mistwang

    mistwang LiteSpeed Staff

Share This Page