GUI Error in 4.1.3 w/ Symlinked httpd_config.xml

Discussion in 'Bug Reports' started by Atticus, Aug 13, 2011.

  1. Atticus

    Atticus New Member

    Hi there,

    I just noticed that all of my Litespeed 4.1.3 web servers are giving generally the same error when I try to do anything requiring it to access httpd_config.xml except on the General page.

    /usr/lsws/conf/httpd_config.xml is a symbolic link on all of our web servers. The file is readable and Litespeed is able to startup and operate using the file. The GUI, however, gives one of the following errors:

    1. failed to open file /usr/lsws/conf/httpd_config.xml
    2. /usr/lsws/conf/httpd_config.xml is not a valid file.

    Given that Litespeed is able to function correctly and the General page in the GUI can parse the VHosts from httpd_config.xml leads me to believe its a bug. Let me know what you think.

    Thanks!
  2. webizen

    webizen New Member

  3. Atticus

    Atticus New Member

    Sorry for this large delay in my response. This issue is pretty low on the priority list as it doesn't affect service. The link you provided does not appear to apply.

    admin_php is running as lsadm on the server. /usr/lsws/conf/httpd_config.xml is owned by lsadm:lsadm and is, by default, chmod 0777 as it is a symbolic link. The symbolic link points to /.../lsws/httpd_config.xml which is chmod 0600 and is owned by lsadm.

    Litespeed server, itself, can follow the symbolic link and has no problem operating normally. The GUI, however, breaks as long as this file is a symbolic link. Removing the symbolic link and copying the file in its place results in the GUI working properly.

    Litespeed's GUI had no problem with this file being a symbolic link until we upgraded to 4.1 Enterprise.
  4. webizen

    webizen New Member

    pls paste the result from the followings:
  5. Atticus

    Atticus New Member

    Okay, something in how Litespeed acted between 4.0 and 4.1 changed which made the permissions on my shared config folder no longer valid. The folder is owned by lsws and only had read access to members of its UID/GID. While looking into this I came across another issue that your opinion could be useful on. Setting the folder permissions to 0751 fixed the "invalid file" error.

    Trying to secure our account folders in /home has led me to set permissions to 0751 (drwxr-x--x). Litespeed can read all the files it needs to properly from these folders, but the GUI won't let me specify those folders in fields stating the folder is not readable. The folder is readable, but only when a specific file is requested as is the norm for Litespeed. The GUI seems oblivious to this.

    Do you know how I can accomplish this goal?
  6. webizen

    webizen New Member

    By default, lsws runs as nobody. GUI as lsadm. You need lsadm to be the group member of the account in question.

Share This Page