Having problems after installing Lite Speed

Discussion in 'General' started by ThrillerVPS, Nov 26, 2013.

  1. ThrillerVPS

    ThrillerVPS New Member

    Hey,

    Guys theses are the problems im getting when i login to the admin panel i get theses errors at the buttom of the log


    Code:
    2013-11-26 15:35:33.907	ERROR	[config:server:epsr:lsphp55] invalid path - /usr/local/lsws/fcgi-bin/lsphp55, it cannot be started by Web server!
    2013-11-26 15:35:33.907	ERROR	[config:scripthandler] Can not find handler with type: 12, name: lsphp55.
    2013-11-26 15:35:33.907	ERROR	[config:scripthandler] Can not find External Application: lsphp55, type: lsapi
    2013-11-26 15:35:33.907	ERROR	[config:scripthandler] use static file handler for suffix [php55]

    Then when i go into the php compiler i get this

    Input error detected. Please resolve the error(s).

    in this what's inside the box

    /lsphp5

    this my first time installing light speed can you guys help me please
  2. mistwang

    mistwang LiteSpeed Staff

    You need to fix
    You need to build PHP 5.5.x with LSAPI 6.6 then make sure /usr/local/lsws/fcgi-bin/lsphp55 is valid.
    You can build PHP 5.5.x from our web console, or if you use cPanel or directadmin, you can build matching PHP from the control panel plugin.
  3. ThrillerVPS

    ThrillerVPS New Member


    ok when i try i get this

    Input error detected. Please resolve the error(s).

    *Illegal location
    /lsphp5
  4. mistwang

    mistwang LiteSpeed Staff

    use /usr/local/lsphp55 instead.
  5. hd-sam

    hd-sam New Member

    I have this exact same error appearing in our error logs, however We are using PHP 5.3.27, and have never installed 5.5.X.

    This is a cPanel box with LiteSpeed WS 4.2.6.
  6. justint

    justint New Member

    I'm having the same problem right now, although I'm using directadmin. Is it fine to leave it like it is?
  7. Michael

    Michael Administrator Staff Member

    No. You will need to build PHP for LSWS. The DirectAdmin control panel plugin has a link for this that will give you a command to run. LSWS will not be able to use PHP until you have built a PHP binary for LSWS.

    (By the way, this issue is not related to the PHP version number. PHP needs to be built for LSWS no matter what version you use.)

    Cheers,

    Michael
  8. justint

    justint New Member

    It was built already, and we are using it to serve our php website for 2 weeks now. I'm not sure why are we getting this error.
  9. webking_amsterdam

    webking_amsterdam New Member

    I have the same error messages:

    2014-06-04 23:15:38.513 ERROR [config:scripthandler] Can not find handler with type: 12, name: lsphp55.
    2014-06-04 23:15:38.513 ERROR [config:scripthandler] Can not find External Application: lsphp55, type: lsapi
    2014-06-04 23:15:38.513 ERROR [config:scripthandler] use static file handler for suffix [php55]
    2014-06-04 23:50:31.125 ERROR [config:server:epsr:lsphp55] invalid path - /usr/local/lsws/fcgi-bin/lsphp55, it cannot be started by Web server!
    2014-06-04 23:50:31.125 ERROR [config:scripthandler] Can not find handler with type: 12, name: lsphp55.
    2014-06-04 23:50:31.125 ERROR [config:scripthandler] Can not find External Application: lsphp55, type: lsapi
    2014-06-04 23:50:31.125 ERROR [config:scripthandler] use static file handler for suffix [php55]

    After the first series of error messages I rebuilt PHP with the WebAdmin interface, but similar error messages still persist.

    How to be sure that the rebuild was done correctly in view of these ( persistent ? ) error messages ?

    What to do next now ?

    How to: "make sure /usr/local/lsws/fcgi-bin/lsphp55 is valid"

    Sorry for asking not being seasoned system admins struggling to familiarize us with the specifics of Litespeed.

    Why not let trial users submit a ( free ) support request ?

    Or alternatively post a good YouTube installation video solving the most frequent problems.

    Thanks.
    Last edited: Jun 5, 2014
  10. NiteWave

    NiteWave Administrator

    I admit those error messages may confuse new users a lot.
    actually it can be ignored, its purpose is to support multiple php version, especially for latest php 5.5.

    to have the error message disappear, is simple:
    #cd /usr/local/lsws/fcgi-bin
    #ln -s lsphp5 lsphp55
  11. webking_amsterdam

    webking_amsterdam New Member

    Thanks for your quick reply !

    We also installed CloudLinux with their php Selector application. Users in cPanel can now easily select ( self service ! ) whatever php version they need in their user accounts.Giving more functionality and a better user experience without a lot of support requests. Our objective !

    So supporting multiple php versions is exactly what we want.

    CloudLinux helped us with access to free support ( also for trial users ) and even did a complete hands on remote re-install and re-configured our server ...

    Will your instructions solve the underlying mis configuration or does it stop the error message from appearing ?

    Finally will php Selector of CloudLinux remain fully functional without throwing error messages ( and multiple support requests ! ) due to this cause ?


    Thanks !
    Last edited: Jun 5, 2014
  12. NiteWave

    NiteWave Administrator

  13. webking_amsterdam

    webking_amsterdam New Member

    After executing your commandline instructions ( from above):

    to have the error message disappear, is simple:
    #cd /usr/local/lsws/fcgi-bin
    #ln -s lsphp5 lsphp55

    and graceful restart of Litespeed gone are the error messages in the main WebAdmin window.

    Thanks for pointing me with the weblink to information on setting up Litespeed to handle multiple PHP configurations for non CloudLinux users.

    CloudLinux phpSelector offers the widest possible selection of choices for cPanel end users ( self service ).

    See below how easy (without Litespeed) in WHM and ultimately in cPanel end users can select their requirements through the GUI interface:

    http://docs.cloudlinux.com/index.html?php_selector.html

    More info on CloudLinux phpSelector:

    http://docs.cloudlinux.com/index.html?php_selector.html

    So what is our next step to getting it all work together ?

    Litespeed - CloudLinux - phpSelector - CageFS




    Thanks !
    Last edited: Jun 5, 2014
  14. NiteWave

    NiteWave Administrator

  15. webking_amsterdam

    webking_amsterdam New Member

    Thanks again !

    Will be digesting this and other information in the meantime !

    Found the following YouTube videos of Litespeed useful for a better understanding::


    Complete WHM/cPanel setup with Litespeed web server ( 36 minutes )


    Installing LiteSpeed to Replace Apache Cpanel/WHM
    Last edited: Jun 8, 2014

Share This Page