How to get workingwith plesk?

Discussion in 'Install/Configuration' started by wflynn, Aug 8, 2007.

  1. wflynn

    wflynn New Member

    The wiki for installing on plesk goes to other control panels but doesn't work on plesk? I am able to get into the control panel of litspeed but whenever I try to set the httpd.conf file inside the control panel and restart litespeed I lose access to litespeeds control panel and websites will not display with the port I selected? Is there a wiki for plesk that doesnt default to other control panels?
  2. mistwang

    mistwang LiteSpeed Staff

    We are working on this. Maybe some configuration in the httpd.conf generated by plesk is causing trouble.
  3. wflynn

    wflynn New Member

    What do you suggest I try or can u help if I send you a copy of the httpd.conf file?
  4. mistwang

    mistwang LiteSpeed Staff

    That will be great if you can.
    Please include all configuration file included by the main httpd.conf, please send it to bug @ litespeedtech ... , we will keep those file confidential.

    Thanks!
  5. mistwang

    mistwang LiteSpeed Staff

    We do not need the SSL related files, those are confidential.
  6. wflynn

    wflynn New Member

    Did you get the files? Do you need anything else? Anxious to try this out to see if it solves my problems.
  7. mistwang

    mistwang LiteSpeed Staff

  8. wflynn

    wflynn New Member

    I really appreciate your help - what is the URL of the wiki so I can view the instructions?
  9. mistwang

    mistwang LiteSpeed Staff

  10. wflynn

    wflynn New Member

    Installed but sites not all working?

    Some sites ask for a password others .htaccess errors?
    www,uslister.com:2080/ gets this .htaccess error:
    [[HTAccess]] rewrite: invalid rewrite condition while parsing: RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##

    If you goto www.pokerpartys.com:2080/ it promptsw you for a password?
  11. mistwang

    mistwang LiteSpeed Staff

    The first .htaccess error probably is because the comment at the end. start it at another line, it should be fine.
    For the other site, there might be some issues with the .htaccess configuration for that site. please send us the .htaccess file.
  12. wflynn

    wflynn New Member

    Getting there I think

    Now when you goto www.uslister.com:2080 you get:

    Warning: Unknown(): open_basedir restriction in effect. File(/home/httpd/vhosts/uslister.com/httpdocs/index.php) is not within the allowed path(s): (none) in Unknown on line 0

    Warning: Unknown(/home/httpd/vhosts/uslister.com/httpdocs/index.php): failed to open stream: Operation not permitted in Unknown on line 0

    Warning: (null)() [function.include]: Failed opening '/home/httpd/vhosts/uslister.com/httpdocs/index.php' for inclusion (include_path='.:/usr/local/lib/php') in Unknown on line 0
  13. wflynn

    wflynn New Member

  14. mistwang

    mistwang LiteSpeed Staff

    OK, "none" is a special value need to be treated differently. Will fix that.

  15. mistwang

    mistwang LiteSpeed Staff

    Anything special for this vhost? can you send us the vhost configuration for this one?
  16. wflynn

    wflynn New Member

    A few of my sites prompt for password I will send u the conf for pokerpartys
  17. wflynn

    wflynn New Member

    Sent you my httpd.include for pokerpartys to bug@litespeedtech.com thats what you wanted right? Also what can we do about the uslister issue? If we get this working 100% on my server and I see a big enough performance gain I will purchase enterprise.
  18. mistwang

    mistwang LiteSpeed Staff

    We are working on it.
  19. wflynn

    wflynn New Member

    I know why some of my sites popup asking for a password - it's all the sites that plesk configured protected directories in. Apparently litespeed is protecting the entire site on these. I don't know how to fix it though other then removing the protection from directories I need them in. I tested the theory on pokerpartys.com and was correct.

    I still don't know how to configure www.uslister.com:2080 either still shows the same errors when I turn on error reporting.
  20. wflynn

    wflynn New Member

    Also I didn't install eaccelerator at time of install and when I try to add now using: /root/sources/lsws-3.2.1/admin/misc/enable_phpa.sh after I choose eaccelerator choice 2 I get error saying: [ERROR] Cannot find PHP executable, not able to determine PHP version - also tried APC same error. I then went and reinstalled litespeed from the beginning and was able to add eaccelerator that way. Just info you may need to improve enable_phpa.sh.
    Last edited: Aug 11, 2007

Share This Page