Howto disable 'detect loop redirection'?

Discussion in 'Bug Reports' started by tomcatter, Feb 1, 2005.

  1. tomcatter

    tomcatter New Member

    Okay, have tomcat + lsws working but...

    I've deployed a struts-based application to tomcat. The application uses custom extensions for identifying the actions to deploy. Long story short, an incoming url that ends with (in my case) '.jnet' is processed by the servlet, some layers of redirection occur, and the browser is then pointed to a specific jsp page for rendering.

    This works great using the straight tomcat connection on port 8080, also works in WebLogic et. al., but LSWS throws errors in the log files about 'detect loop redirection' and the browser gets the 404 error.

    How do I disable the loop redirection stuff, or is this a bug?
  2. mistwang

    mistwang LiteSpeed Staff

    Like Apache, LSWS performs internal redirect if the target URL is a relative URL without leading "http://". During the internal redirection, no duplicate URL with same parameters is allowed.

    To avoid the internal redirect, you can change your redirect url to a absolute URL.

    Please turn on debug log by changing "debug level" to "high" under "Server"->"General" tab, you will find out what is happening. If need more help, please post lsws/logs/error.log here.

Share This Page