:( HTTP Error 405 - Method not allowed :(

Discussion in 'General' started by anisawants2growup, Jun 26, 2009.

  1. anisawants2growup

    anisawants2growup New Member

    Today got the message

    405 Method Not Allowed
    This type request is not allowed! Powered By LiteSpeed Web Server
    Lite Speed Technologies is not responsible for administration and contents of this web site!

    This was generated every time someone needed to post his/her comments to the site. The script is written in cgi. Then i noticed that in Litespeed logs there is the WARNING saying:

    [config:server:listener] No listener is available for normal virtual host!

    Also my IP-s in their 443 port had N/A Virtual server mapped to.


    Have nearly 0 knowledge in this thing but my intuition insist in a relation between the 405 error and the absence of the virtual server.

    What am i suposed to do??

    Any clues?

    Thanks in advance
  2. anisawants2growup

    anisawants2growup New Member

    Connection Soft Limit set to 1000

    Previously there was some other guy taking care of the matters, that is why the environment is pretty unknown to me. I noticed that the connection soft limit was set to 1000 while the recommended being 5 - 10. I came to know that during grace period this number exceeds a little still remaining under the Connection Hard Limit.

    However yesterday, during one of the graceful restarts somehow a comment managed to be posted.


    Pleeeeease anyone can have any idea why my cgi files reach to the HTTP Error 405 Method not allowed???





  3. mistwang

    mistwang LiteSpeed Staff

    There should not any problem to POST to a CGI script. Are you sure your CGI script has not been served as static file?
  4. anisawants2growup

    anisawants2growup New Member

    Danger probably lurking in "Server stopped" notice?

    I guess u are right.


    There are four websites served by Litespeed: two of them are build upon Movable Type! And they both give the 405 Method Error each time you need to post a comment, which they have not done previously. That is why i thought there were some trouble with cgi-s configuration in server. But that would certainly cause far more problems.

    I checked the comment form after ur reply, and POST method is used there. But i read that POST is enabled in Litespeed.

    I dunno anymore were this hole mess is lying.

    After restarting, I noticed a "Server stopped" - and read in one of ur forums that it maybe due to the access.log size. In fact, the apache log files have surpassed the 2 Giga, which has caused pretty much trouble lately. Do u believe this could be my case too? And if so, will a normal delete of the access logs be enough to get rid of the problem?

Share This Page