instruction or user error?

Discussion in 'Install/Configuration' started by dracozny, Nov 25, 2011.

  1. dracozny

    dracozny New Member

    from:http://www.litespeedtech.com/support/wiki/doku.php?id=litespeed_wiki:php:lsapi
    Code:
     php-5.3.8 # ./configure '--prefix=/lsphp5' '--with-litespeed' --with-mysql=/usr/lib64/mysql
    
    make
    Code:
    php-5.3.8 # make install
    Installing PHP SAPI module:       litespeed
    Installing PHP LiteSpeed into: /lsphp5/bin/
    Installing PHP CLI binary:        /lsphp5/bin/
    Installing PHP CLI man page:      /lsphp5/man/man1/
    Installing build environment:     /lsphp5/lib/php/build/
    Installing header files:          /lsphp5/include/php/
    Installing helper programs:       /lsphp5/bin/
      program: phpize
      program: php-config
    Installing man pages:             /lsphp5/man/man1/
      page: phpize.1
      page: php-config.1
    Installing PEAR environment:      /lsphp5/lib/php/
    [PEAR] Archive_Tar    - installed: 1.3.7
    [PEAR] Console_Getopt - installed: 1.3.0
    [PEAR] Structures_Graph- installed: 1.0.4
    [PEAR] XML_Util       - installed: 1.2.1
    [PEAR] PEAR           - installed: 1.9.4
    Wrote PEAR system config file at: /lsphp5/etc/pear.conf
    You may want to add: /lsphp5/lib/php to your php.ini include_path
    /.../php-5.3.8/build/shtool install -c ext/phar/phar.phar /lsphp5/bin
    ln -s -f /lsphp5/bin/phar.phar /lsphp5/bin/phar
    Installing PDO headers:          /lsphp5/include/php/ext/pdo/
    php-5.3.8 # cd /opt/lsws/fcgi-bin/
    bash: cd: /opt/lsws/fcgi-bin/: No such file or directory
    
    I think either I missed something or the --prefix setting in the instructions is incorrect
  2. webizen

    webizen New Member

    /opt/lsws/ is the install directory of lsws which has nothing to do with --prefix.

  3. dracozny

    dracozny New Member

    there is nothing in /opt
    Code:
    php-5.3.8 # ls /opt
    php-5.3.8 # 
    
    based on the prefix I have files in /lsphp5 which is easily confirmed
    Code:
    php-5.3.8 # ls /lsphp5/
    bin  etc  include  lib  man
    
    and even changing prefix to /opt/lsws that does not give /opt/lsws/fcgi-bin..
    Last edited: Nov 25, 2011
  4. webizen

    webizen New Member

    /opt/lsws is an example. if your lsws is installed at /usr/local/lsws, then that's the path you should go with.
  5. dracozny

    dracozny New Member

    no I think i realized the problem, i was following the wrong install instructions from the start.
  6. webizen

    webizen New Member

    ok. for others' information: the wiki link posted earlier is for lsphp (LSAPI + PHP) compile/install *NOT* LSWS install (as stated in article title).

Share This Page