ispCP index.php displays a blanc page

Discussion in 'Install/Configuration' started by lod, Jun 24, 2010.

  1. lod

    lod New Member

    Hello !

    I was using apache a long time and I read about the advantages of Litespeed
    and they convinced me to switch.

    I installed Litespped and so far everything went just fine. The Website I am
    hosting runs verry smooth and so far there were no problems.

    But Im using ispCP and thats where the trubble starts. I cant access the
    ispPC control pannel anny longer. It just displays a blanc page.

    When I rename the index.php of the GUI to (for example *.bku) I get an
    "page not found" and when I rename it back to index.php I ll get that
    blanc page again.

    I even tryed to change the port of the Hostingcontrollpannel but then I`ll get the blanc page on that port.

    I would appreciate anny kind of Help or suggestion ! :)
  2. NiteWave

    NiteWave Administrator

    no experience with ispCP.
    how about a plain index.html, can it display right?
  3. lod

    lod New Member

    Thank you for your reply !

    Yes it can. I copyed the "It works" index.html into the ispCP/gui directory
    and that works just fine.

    Edit:

    A coworker and me checked the ispCP setings over and over and they are correct. I think they have to be, because ispCP works just great with apache.
    Last edited: Jun 26, 2010
  4. mistwang

    mistwang LiteSpeed Staff

    ispCP may require a PHP module that does not exist in LiteSpeed PHP, You should rebuild PHP with exact the same configuration option like Apache's PHP. Just display phpinfo() page from both, and compare if all configuration options, runtime configuration, and modules are the same.
  5. mistwang

    mistwang LiteSpeed Staff

    change php.ini to allow PHP dump errors to screen or log file, so, you will get an idea what happened with PHP.
    Try changing index.php, only display phpinfo() to test PHP installation works or not.

Share This Page