Large PHP Uploads Stall/Fail

Discussion in 'Install/Configuration' started by dlewis23, Mar 22, 2011.

  1. NiteWave

    NiteWave Administrator

    have you done same tests before 4.1.12 ?
  2. eray2509

    eray2509 New Member

    no, I haven't done any test before 4.1.12
  3. eray2509

    eray2509 New Member

    i login litespeed account, uploading file and i see this error log litespeed panel

    2012-04-04 17:24:24.604 WARN Remove looping fd: 197, event: 1

    what is it means?


    sorry bad english :(
  4. NiteWave

    NiteWave Administrator

    please test upload on 4.1.11

    4.1.12 will be there, it's easy to switch between 4.1.11 and 4.1.12 in

    lsws admin console->Actions->Version Manager
  5. eray2509

    eray2509 New Member

    ok, downgrade litespeed version now
  6. eray2509

    eray2509 New Member

    I tried again to upload a file. breaking up a complete connection with the server for a few seconds. stops access to sites and litespeed error log


    Found 3 warning/error messages in the log:
    Time Level Message
    2012-04-05 08:05:05.472 WARN Remove looping fd: 74, event: 1
    2012-04-05 08:06:42.886 WARN Remove looping fd: 54, event: 1
    2012-04-05 08:08:22.039 WARN Remove looping fd: 99, event: 1
  7. eray2509

    eray2509 New Member

    litespeed version changing 4.1.11 and i have done some tests. everything working fine! problem is solved. but this problem is bug for 4.1.12.

    thanks!
  8. mistwang

    mistwang LiteSpeed Staff

    Would you like to help us figuring out what is wrong with this?
    If yes, please remove existing error log, change "Log Level" to "debug", "Debug Level" to "high", do the test again with 4.1.12. send us the log file, along with you IP address, so we can track related log entries in error.log with your IP.

    Please send the compressed log file to bug@litespeedtech...
  9. justme

    justme Member

    Hi,
    I get this issue with lsws 4.1.x (up to .13, .11 included), on lsws standard on x64 (ubuntu 11.10), with php-fpm 5.3.6 tweaked (upload size, max body size, uploadprogress), running wordpress 3.4.1.
    Any idea on how to get around this issue?
    while the stall happens lshttpd is using 100% cpu
    89.92.x 0 PR 208.5 120086/120086 0/0 foo.fr php-fpm 209 POST /wp-admin/async-upload.php HTTP/1.1

    thanks for your help!
  10. webizen

    webizen New Member

    As mistwang put it, enable debug logging and send us compressed log to investigate.
  11. justme

    justme Member

    Done.
    it loops on
    2012-08-01 13:10:30.220 [DEBUG] EdStream::handleEvent(), fd: 16, event: 4
    2012-08-01 13:10:30.220 [DEBUG] EdStream::handleEvent(), fd: 16, event: 4
    2012-08-01 13:10:30.220 [DEBUG] EdStream::handleEvent(), fd: 16, event: 4
    2012-08-01 13:10:30.220 [DEBUG] EdStream::handleEvent(), fd: 16, event: 4
    2012-08-01 13:10:30.220 [DEBUG] EdStream::handleEvent(), fd: 16, event: 4
    2012-08-01 13:10:30.220 [DEBUG] EdStream::handleEvent(), fd: 16, event: 4
    2012-08-01 13:10:30.220 [DEBUG] EdStream::handleEvent(), fd: 16, event: 4
    It filled several GB of logs in a few minutes!
  12. gnu.smtp

    gnu.smtp New Member

    Hello,

    Any update/progress on this. We have a wordpress stalling the upload for large files.
  13. webizen

    webizen New Member

    justme's server is weak (t1.micro amz instance) and running fcgi. suggest him to run lsphp with a more powerful server.

    for your case, how large is the file? check /tmp to make sure it has enough space. also check error log for any clue.
  14. gnu.smtp

    gnu.smtp New Member

    Hi,

    On our server the file size is 50 Mb mp3 file. It works fine if we restart http.

    /tmp on the server is 2G and have more than 1.5G free space.
  15. NiteWave

    NiteWave Administrator

  16. gnu.smtp

    gnu.smtp New Member

    Hi,

    We have enough memory limits mentioned above. But this doesn't work.
  17. webizen

    webizen New Member

    upload related limits (such as upload_max_filesize, etc) have to do with those set in php.ini as nitewave pointed out apart from /tmp free space. pls double check.

Share This Page