large static file downloads stop at 50MB

Discussion in 'Install/Configuration' started by mblyman, May 13, 2009.

  1. mblyman

    mblyman New Member

    I am currently have a host that is using litespeed and I am getting an issue when downloading large static files.

    The download of any file stops at 50 MB regardless of the file size. Some are 52 MB others 80 MB and no matter the original size it stops at 50 MB as if it had completed the download without any errors.

    Of course if I try to open the file it is corrupt because it didn't completely download.

    I'm using Magento ecommerce to run digital download products and this is where the issue I believe it happening is with litespeed and perhaps some configuration setting.

    I have two different servers, one is running apache and then one running litespeed. Only the litespeed server is causing issues with the digital downloadable products in magento.

    If it helps the downloads are all via https rather then http.

    Has anyone heard of this issue before?

    Thanks

    Mike
  2. auser

    auser Super Moderator

  3. Bono

    Bono New Member

    My users complain about that too, sometimes it breaks really fast, and sometimes near the end.

    I have tried just now, size of the file 58MB, it broke at 10MB.

    Second try, same file in IE 8 it broke at 48MB.

    Hmm after five tried it looks like that it usually brakes at 10.02MB.
    Last edited: May 13, 2009
  4. anewday

    anewday Moderator

    All all these files served through PHP?
  5. Bono

    Bono New Member

  6. mblyman

    mblyman New Member

    To help coordinate efforts on this issue here is the link to the thread on the magento forums.

    http://www.magentocommerce.com/boards/viewthread/41264/

    based on what is being said it appears that it is a litespeed issue rather then application issue like magento or joomla or other 3rd party scripts used for downloading files.
  7. mblyman

    mblyman New Member

    @Bono

    All the files in magento commerce are served through PHP as well
  8. auser

    auser Super Moderator

    I took a quick look at DOCman source code, the downloaded file is sent to user by .php, so its size is limited by "Max Dynamic Response Body Size" I mentioned in previous post. try to increase it to 100M/200M and see how it goes.

    to compare with pure static file download, you can put a large file, say aaa.tar(80M) at document root, and access it by direct link http://www.yourdomain.com/aaa.tar, see if the file can be downloaded completely.
  9. Bono

    Bono New Member

    Very nice, I used 100MB and my downloads are fixed. My biggest file is only 80MB big so 100MB will be more than enough.

    Funny thing was I had error msg in LSWS control panel but I thought it is error from my web gallery.

    "The size of dynamic response body is over the limit, abort!"
  10. mistwang

    mistwang LiteSpeed Staff

  11. Bono

    Bono New Member

    You are right, that would be more efficient way but since that site is low profile it can stay like this. If it was high profile site, it would really soon eat up all the memory. Maybe in new version of DOCman that is fixed, but I'm still using older version.

    Thanks
  12. mblyman

    mblyman New Member

    My host fixed it as well and here is what they said about the setting they changed.

    “It was a setting for litespeed under I believe it was “Tuning” for “max post size” was 50M set this to 1000M (the max)

    I'm not sure if this is the same or something different then the setting referenced earlier in the post
  13. Bono

    Bono New Member

    They used that option, but if you do not have files close to 1GB, that setting is overkill.
  14. auser

    auser Super Moderator

    "max post size" should be "Max Dynamic Response Body Size (bytes)" referred in this thread.
    It's quite reasonable to increase it to resolve the issue.
    Last edited: May 15, 2009

Share This Page