LiteSpeed 2.1.12 Standard with Rails...

Discussion in 'Ruby/Rails' started by hugemikeyd, Mar 9, 2006.

  1. hugemikeyd

    hugemikeyd New Member

    I am having an issue with getting Ruby On Rails to run properly with the server. Everything works fine from within WEBrick, but not with LiteSpeed. I followed a set of directions i found on the web to a T, but things are not working as they should. From what i have gathered, the rewrites are not working correctly and the dispatcher.fcgi is having difficulty processing the request. I always get a timeout error from the server. Also, i cannot just go to the index of the host, i need to have index.html to make the index show, but the view enironment setting does not work properly. I also tried creating a new controller and that does not process either. Is there a simple way for me to post my configuration?

    Thanks to all for any information :)
  2. mistwang

    mistwang LiteSpeed Staff

    Some quick notes regarding Rails:

    1. turn off persistent connection for the dispatch.fcgi, Ruby's fcgi interface does not support persistent FCGI connection.

    2. Turn on .htacess support at both vhost and server level to make the rewrite rule in public/.htaccess work properly. You probably did not turn it on at server level.

    3. Once the rewrite rule works, index.html should work properly. You can also add "index.html" as a index page for that vhost.
  3. hugemikeyd

    hugemikeyd New Member

    i had already turned off the persistant connection with the fcgi, as i had read that it wouldn't work at all if that option was enabled.

    Also, for the rewrite rules, i moved them into the configuration of the server:
    Code:
    RewriteRule ^$ index.html [QSA]
    RewriteRule ^([^.]+)$ $1.html [QSA]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]
    
    but i will give it a shot with your way[/code]
  4. mistwang

    mistwang LiteSpeed Staff

    The rewrite rules will be slightly different when configured at vhost level, Both matching URL and target URL should be full URL, not relative URLs. It should work if you fix the URLs.
  5. hugemikeyd

    hugemikeyd New Member

    yes that did indeed work!

    man that was easy lol, thanks for your help :D
  6. hugemikeyd

    hugemikeyd New Member

    i take it back, now only the index.html rewrite is working, nothing else...
  7. mistwang

    mistwang LiteSpeed Staff

    Have you change the last line of rewrite rule to

    Code:
    RewriteRule ^(.*)$ /dispatch.fcgi [QSA,L] 
    Have you defined a FCGI context with URI /dispatch.fcgi and pointing it to the dispatch.fcgi application?
  8. hugemikeyd

    hugemikeyd New Member

    yes i have done that and i just realized that i did not have fcgi installed, so i compiled that and i am still in the same spot. Am i supposed to create a script handler at the server level like php is set up?
  9. mistwang

    mistwang LiteSpeed Staff

    No need to configure a script handler, just defined a FCGI context with URI /dispatch.fcgi and pointing it to the dispatch.fcgi application.
  10. hugemikeyd

    hugemikeyd New Member

    I know that it has been a week but i continued to play with it all and it all works beautifly!

    I am seeing 50 requests per second with a basic rails page, this is on the standard server vs. around 30 for Lighttpd, i am extremely impressed with the performance of this sever...

    Thanks again for all of your help :D
  11. mistwang

    mistwang LiteSpeed Staff

    You are welcome.
    Glad that you are happy with our product.

Share This Page