Litespeed 4.1.13 - xcache cannot be used by W3 Total Cache

Discussion in 'Install/Configuration' started by notoroder, Sep 5, 2012.

  1. notoroder

    notoroder New Member

    I am using Litespeed 1 CPU Enterprise and trying to use W3 Total Cache on my WordPress site.

    xcache been install on my VPS WHM

    and also can be detected by W3 Total Cache but i can only use it for database caching not object caching...

    Error Details

    1.while trying xcache as database cache it saved.. no error.. but as soon i try to empty the cache.. i get this error

    Code:
    Fatal error: xcache_clear_cache() [<a href='http://xcache.lighttpd.net/wiki/InstallAdministration'>http://xcache.lighttpd.net/wiki/InstallAdministration</a>]: xcache.admin.user and/or xcache.admin.pass settings is not configured. Make sure you've modified the correct php ini file for your php used in webserver. in /home/******/public_html/wp-content/plugins/w3-total-cache/lib/W3/Cache/Xcache.php on line 86
    2.Now Next error..When i try to use xcache as object caching

    http://i.imgur.com/4X1ED.png

    i get this

    [​IMG]


    For ref here is the xcache.php

    http://pastebin.com/JJ3J2HL2


    3.About Page caching I can only use Disk option not disk Enhanced.. as always it gvs me error

    Code:
    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.
    

    4.And Also i have APC installed. but i cannot use it..

    here is the proof as its been installed

    [​IMG]

    and here is the option stating i cannot use it

    [​IMG]

    as u can see its greyed out...

    I know i asked mny things but I would rly need this get solved.. as i dnt know much abt LS or WHM.. all installation done by vps provider. and they hv less time for fixing this
  2. NiteWave

    NiteWave Administrator

    looks like php/xcache related issues, not litespeed specific. should have same issue when running under apache.

    question: php suExec enabled or not?

    check your setting of:
    lsws admin console->Configuration
    ->Server->General->PHP suEXEC
  3. notoroder

    notoroder New Member

    yes it is enabled

    [​IMG]
  4. webizen

    webizen New Member

    to use xCache, PHP suEXEC needs to be disabled.

  5. notoroder

    notoroder New Member

  6. webizen

    webizen New Member

    make sure matching PHP is built in WHM LSWS plugin.
  7. notoroder

    notoroder New Member

    @webizen IF its ok.. can u chk it for me i will pm u the console address and login...

    i just want to use xcache and acp in w3total cache on wordpress...
  8. webizen

    webizen New Member

    check xcache.var_size in /usr/local/lib/php.ini. make sure it is non-zero.
  9. notoroder

    notoroder New Member

    well i changed it to 32M didnt work.. so changed it back to 0
  10. webizen

    webizen New Member

    pls pm to me.
  11. notoroder

    notoroder New Member

    @webizen PM sent
  12. webizen

    webizen New Member

    turns out LSWS was not restarted to make the change effective.
  13. notoroder

    notoroder New Member

  14. webizen

    webizen New Member

  15. notoroder

    notoroder New Member

  16. webizen

    webizen New Member

    1. how much is server RAM?
    2. also check /usr/local/apache/logs/error.log and stderr.log for any details.
    3. comment out either "extension=apc.so" or "extension=xcache.so" so only use one opcode cache.
    Last edited: Sep 7, 2012
  17. notoroder

    notoroder New Member

  18. webizen

    webizen New Member

    Your system memory is limited. Please do both 1 and 2 below:

    1. Lower your LSPHP5 memory (soft/hard) limit to 256MB/300MB
    2. Comment out either opcode cache (apc or xcache) in php.ini or both of them.
  19. notoroder

    notoroder New Member

    so as i understand correctly .. as my systm memory is limited. its best tht i do not use apc or xcache
  20. webizen

    webizen New Member

    you can enable one and leave other off and see if memory is often run out. If it is the case, then you have to keep both of them off.

Share This Page