LiteSpeed compatibility issue with cPanel > cPanel blocking LiteSpeed

Discussion in 'Install/Configuration' started by vivek, Mar 2, 2008.

  1. aww

    aww New Member

    Thank you for this. Just in time too as I had to leave for the day and was about to try the other auto-monitoring/restart script (which actually I would like to see as a extra feature someday if possible)

    Is there a command we can do to test that this new script is working without waiting until after midnight for the cpanel auto-update ;)

    ps. thank you Vivek for helping them solve this so quickly!
    Last edited: Mar 8, 2008
  2. felosi

    felosi New Member

    I dont think this is restarting litespeed though. The pid is not changing for me. Here is usual output:

    [root@cp ~]# service httpd restart
    /etc/init.d/httpd restart: httpd not running, trying to start
    [ERROR] lshttpd is running with pid=22020.
    /etc/init.d/httpd restart: httpd could not be started
    [root@cp ~]# ps -u nobody
    PID TTY TIME CMD
    22031 ? 00:00:00 lshttpd
    22032 ? 00:00:01 lshttpd
    [root@cp ~]# service httpd restart
    /etc/init.d/httpd restart: httpd not running, trying to start
    [ERROR] lshttpd is running with pid=22020.
    /etc/init.d/httpd restart: httpd could not be started
  3. mistwang

    mistwang LiteSpeed Staff

    Have you download and update to the latest 3.3.7 release ?
  4. mistwang

    mistwang LiteSpeed Staff

    Add or terminate an account.
  5. felosi

    felosi New Member

    Ok got it working now, thanks a lot george
  6. ffeingol

    ffeingol New Member

    And this is prob. going to be a lot more fun and joy as everyone (should) have just patched cPanel yesterday for the Horde exploit?
  7. felosi

    felosi New Member

    take note, if you use this method make sure to re-enable httpd in service manager otherwise it will leave it dead when it kills it
  8. aww

    aww New Member

    Too bad I missed that part - I came back to find the server was down again :(

    This is really an ugly hack and I hope the permanent solution is far better.

    Essentially apache is dead in this kind of configuration and if for some reason you wanted to temporarily switch from litespeed to apache and back it would be a huge hassle.
    Last edited: Mar 8, 2008
  9. felosi

    felosi New Member

    also this happened on stable servers as well as release so I dont think its just a thing with versions, stable is doing it as well. Half of my servers that went down the other night were stable
  10. vivek

    vivek New Member

    Thank you very much Mr.George , for fixing the compatibility issue with cPanel servers.
    I am now waiting for version 3.3.8 and I hope this will contain a fix by default.

    But just a question.

    I dont what to uninstall apache permanently. Because sometimes, I may need Apache for some minutes. But with this wrapper script , service httpd restart, will restart litespeed instead of apache. So, If I want apache ,then I have to do ./httpd_ls_bak -k restart after killing lshttpd.
    It will be good if there is a simple way for doing this.

    BTW, can you include the copy of script,
    /etc/rc.d/init.d/httpd with every lsws installation, like
    /etc/rc.d/init.d/http ( and register as service ? ), so that I can start apache as , service http restart ?


    Thanks in advance.
    Vivek
    SunTex Hosting
    Last edited: Mar 8, 2008
  11. ffeingol

    ffeingol New Member

    Hmm, I'm not sure this is a viable solution for those of us proxying the SSI requests back to Apache. This script leaves us with no way to start/stop/restart Apache now (unless I'm missing something).
  12. vivek

    vivek New Member

    Hello mistwang,

    Just now I got that , Apache is disabled and I am not able to start it.

    service lsws stop
    cd /usr/local/apache/bin
    ./httpd_ls_bak -k restart

    or

    ./httpd_ls_bak -k start


    Is not restarting or starting apache.
    Any solution ?

    Vivek
  13. vivek

    vivek New Member

    update:

    Apache is starting with this command

    service lsws stop
    mv httpd httpd_lsws
    mv httpd_ls_bak httpd
    service httpd restart


    Simply I removed the lsws patch. :(

    Any idea for another patch which can also support httpd ?

    Vivek
  14. mistwang

    mistwang LiteSpeed Staff

    ./httpd_ls_bak
    ./httpd_ls_bak -k start -DSSL

    should work.

    Our automated solution will automatically apply/remove the patch based on "Port Offset/IP Offset" configuration in LSWS.
  15. mistwang

    mistwang LiteSpeed Staff

    No need to apply this patch for users who proxy back to Apache.
  16. aww

    aww New Member

    I assume that a long term solution is in the works that will allow us to go back to being able to run httpd and lsws at the same time (or switch off for testing). I can live without apache in the meanwhile as long as it doesn't take too long (like weeks).
  17. aww

    aww New Member

    Okay I have a bigger problem in that the fix with the newer 3.3.7 installed is still not working. I followed the instructions exactly and have turned back on the httpd service.

    Just modified an existing account and it killed the service.
  18. Mani

    Mani New Member

    mistwang

    I think you guys should work faster on this, we badly need a good way to solve this please.
  19. mistwang

    mistwang LiteSpeed Staff

    If you did not download 3.3.7 release manually, you may use the older one.
    bin/lswsctrl has been updated to make it work properly.
  20. vivek

    vivek New Member

    Sorry to say,
    this is not working
    apache is not starting

Share This Page