LiteSpeed compatibility issue with cPanel > cPanel blocking LiteSpeed

Discussion in 'Install/Configuration' started by vivek, Mar 2, 2008.

  1. Mani

    Mani New Member

    the best is to communicate with cpanel and arrange some thing that they wont break it in the next update

    for my self since i dont need apache i arranged to use the other script to check lsws status and run if it is stoped and make sure apache is off, but this wont work for all.
  2. felosi

    felosi New Member

    its not just litespeed, its all thrid party webservers. Any process running on port 80 even apache gets killed.

    Here is how I was finally able to sleep. I done this apache wrapper, dont use apache for anything so it was fine. Then I done the monitor script on one minute cron, then I made sure apache was enabled in service manager in WHM.

    Then I was able to finally not worry about it.

    Cpanel isnt going to work with anyone, we just have to find a way around it.

    It can be done though if you still have to use apache. You could change the init.d script, binary and all that.
    Last edited: Mar 9, 2008
  3. vivek

    vivek New Member

    Yes, thats right. The best way is to use the second scrpit.
    A cron will increase the server load sometimes.

    Vivek
  4. aww

    aww New Member

    Yup the one minute cron did the trick for me last night too (whew) but that's not a long term solution obviously (though I am going to leave it running forever at 5 minute intervals - litespeed essentially should never be down longer than that)

    The wrapper is not working for me.
    It's possible I missed a step but I doubt it.
  5. vivek

    vivek New Member

    Hi

    The wrapper script is working on my 2 servers.

    Did you miss something ? May be I can help you.

    Vivek
  6. aww

    aww New Member

    Well I did follow the instructions exactly.
    But after restoring a backed up account yesterday cpanel restarted the server and it killed lsws with no restart.

    Inspecting the new httpd though, I realize I left the owner as root.
    Do I need to chown httpd to another user?
    The backed up httpd is also owned by root so I thought I should match.
    Last edited: Mar 9, 2008
  7. vivek

    vivek New Member

    Do you have the latest lsws package installed ? 3.3.7 ? If not,please upgrade manually.

    Vivek
    SunTex Hosting.
    www.suntexhosting.com
  8. aww

    aww New Member

    Yes that was the first thing I did after reading all the instructions.

    Here's what I did:
    1. download and install newest 3.3.7 ent
    2. checked that these two paths are correct in the script, which for virtually all cpanel/lsws installs should be:
    LSWS_HOME=/opt/lsws
    APACHE=/usr/local/apache/bin/httpd_ls_bak
    3. cd /usr/local/apache/bin
    4. mv httpd httpd_ls_bak
    5. nano httpd
    6. pasted the new script in and saved
    7. chmod 0755 httpd
    8. went into cpanel WHM Main >> Service Configuration >> Service Manager and checked on "httpd Web Server"

    Last edited: Mar 9, 2008
  9. vivek

    vivek New Member

    Hi

    Looks like everything is fine.
    can you tell me your cPanel build ?

    Vivek
  10. aww

    aww New Member

    WHM 11.15.0 cPanel 11.18.2-R21613
    CENTOS Enterprise 4.6 i686 on virtuozzo - WHM X v3.1.0

    I'm going to try deleting and restoring a test account now just to make sure nothing has changed.

    added: Yup, the server never came back up after the account termination.
    Last edited: Mar 9, 2008
  11. vivek

    vivek New Member


    Here is the fix.

    Goto WHM - > Update Conf
    Select Manual Updates Only (CURRENT tree)
    Click Save

    ssh and update the cPanel version

    /scripts/upcp --force


    Good luck.

    Vivek
  12. travisbell

    travisbell New Member

    Not sure if cPanel undated last night with a fix for this or what, but LiteSpeed was NOT killed last night I and HAVE NOT applied any of the fixes in this thread, or install the cron.

    Anyone else in my boat?
  13. vivek

    vivek New Member

    May be you are using Stable version.

    Are you sure , you are using cPanel current version and the problem is no longer there?

    I will check it on my test vps. Will update later.

    Vivek
  14. vivek

    vivek New Member

    Update:

    I just removed the patch from my test vps, and removed an account.
    Lsws was killed and apache suddently started.

    cPanel did not update anyting.

    You may be using stable version or you did not create/remove accounts last night.
    Thats why litespeed was not killed in your case

    Vivek
  15. travisbell

    travisbell New Member

    Don't think so....

    All I know is that for 4 straight days, LS was killed in the wee hours of the morning and this morning it was not. We have not added any accounts for atleast a week.

    [​IMG]
  16. vivek

    vivek New Member

    Hi

    So, you are using cPanel Release build.

    LiteSpeed cant run on cPanel servers using Current build, without this patch.

    I found STABLE build is working fine with litespeed, but not sure about RELEASE build.


    Vivek
  17. mistwang

    mistwang LiteSpeed Staff

    OK, everyone, please download and try 3.3.8 release. Just change the version number in the download link.

    Two configuration options to change, "Auto Reload on Change" to "Use Apache binary wrapper", set "Apache Binary Path" to where the Apache httpd is.

    This should install the wrapper script automatically. If "Auto Reload on Change" set to "No" or "yes", the wrapper script will be removed during next restart.

    You can also try building a new Apache binary, it should replace the Apache with the wrapper script automatically.

    Also, 3.3.8 might be able to survive even without the wrapper script installed. cPanel may not able to kill it, but I am not 100% sure. Please give it a try as well.
  18. vivek

    vivek New Member

    I think you forgot to add the wrapper script with version 3.3.8 and released in hurry.

    This is the same as before. No wrapper script is packed with this package.

    I checked /usr/local/apache/bin too. The httpd executable file is the same.

    Here is what I did.



    //backing up lsphp and php.ini

    cd /home/lsws/fcgi-bin
    cp lsphp /lsphp
    cd ..
    cd php
    cp php.ini /php.ini

    //uninstalling current version

    cd /home/lsws/admin/misc
    ./uninstall.sh

    //Downloading new version and installing it.


    cd /
    wget http://www.litespeedtech.com/packages/3.0/lsws-3.3.8-ent-x86_64-linux.tar.gz
    tar -zxvf lsws-3.3.8-ent-x86_64-linux.tar.gz
    cd lsws-3.3.8
    echo "MySERIAL NUMBER" > serial.no
    ./install.sh

    //Restoring lsphp and php.ini
    cd /home/lsws/php
    rm -rf php.ini
    mv /php.ini .
    cd ..
    cd fcgi-bin
    rm -rf lsphp
    mv /lsphp .


    killall -9 httpd
    service lsws restart

    Changed option to use Apache wrapper from lsws admin panel.
    then
    service lsws stop
    service lsws start

    I checked /usr/local/apache/bin and found httpd is the same.

    Checked by creating a test domain. And found lsws is killed and httpd is started.


    Did I miss anything ??


    Vivek
  19. mistwang

    mistwang LiteSpeed Staff

    I will check your server if possible.
  20. vivek

    vivek New Member

    Hello

    Thank you. I hope you have my server login details with you.
    I manually created the wrapper script again.

    Please remove it and try updating the Apache wrapper option from the lsws admin panel. I am sure it is not working :(

    Thanks for your time.

    Regards
    Vivek

Share This Page