litespeed fastcgi handler

Discussion in 'Install/Configuration' started by vacancy, Jan 27, 2013.

  1. vacancy

    vacancy New Member

    Hello

    Fastcgi handler option can not be selected via Litespeed, I wonder how on litespeed software handler can run fastcgi, fastcgi run performance in terms of the benefit you?
  2. webizen

    webizen New Member

    you need to build PHP with fcgi api as follows:

    http://www.litespeedtech.com/how-tos.html#qa_phpfcgi

    lsapi + PHP is recommended over fcgi for better performance

    http://www.litespeedtech.com/lsapi-litespeed-server-application-programming-interface.html

  3. vacancy

    vacancy New Member

    Thank you for letting me answer webizen.

    When we compile fastcgi with easyapache via Cpanel, litespeed fastcgi handler is active, will you?
  4. webizen

    webizen New Member

    Nope. it is manual work as indicated in the previous post: you need to compile PHP with --enable-fastcgi--enable-discard-path --disable-path-info-check and create fastcgi handler and link to fcgi external app using the compiled PHP.
  5. vacancy

    vacancy New Member

    hello again

    Php fastcgi protocol is enabled by adding the assembly of LSAP did, but when I compile the assembly and the assembly rules is canceled fastcgi doing without.

    Lsapi configure settings
    --enable-fastcgi--enable-discard-path --disable-path-info-check

    the compilation of LSAPI

    ./configure '--prefix=/usr/local/lsws/lsphp5' '--disable-path-info-check' '--with-litespeed'

    Some fastcgi is automatically canceled.
  6. webizen

    webizen New Member

    you should not use '--with-litespeed'. just to be clear: there is *no* litespeed fastcgi but regular fastcgi.
  7. vacancy

    vacancy New Member

    As you said - with-litespeed part of the erased, but when I compile via LSAP automatically re-added and deleted part of fastcgi.
  8. webizen

    webizen New Member

    What's why I said it is a manual thing. You can not use compile PHP from admin console which will add '--with-litespeed' option automatically. You have to manually compile from command line with needed options.
  9. vacancy

    vacancy New Member

    I added manually following sections.

    However, when I start compiling the following options automatically - with-litespeed added.

    I have added


    If I start the compilation process is as follows


  10. webizen

    webizen New Member

  11. vacancy

    vacancy New Member

    Thank you very much for your help.

    However, the expression wiki page so superficial and not a bad place but I'm choked up and I could not come up. No documents wiki did not help.

    So your customers to torture, rather than compile time option with fastcgi module admin panel, you add or easyapache LSAP fastcgi collection made ​​from active even if you would be so nice on litespeed in the same way.

    Litespeed is a performance-oriented working program to improve its performance must be available in each module, fastcgi support, but not positive to take all this trouble to set up. I hope that makes litespeed developers working on this issue later versions.

    Thanks :(

Share This Page