litespeed have issues with wordpress plugin's

Discussion in 'Word Press' started by amirreza, May 16, 2014.

  1. amirreza

    amirreza New Member

    Hi to everyone and apoligies for my english
    First thank you for your webserver although i have problem's with your webserver but it have many good things the best thing is it's stability. but i wan't to report this problems so you can make it even more greater that what that it was now.
    first problem i encountered is wordfence and litespeed problem
    1 month ago i was on a apache webserver and wordfence work great on my site as my site visitors grow my hosting upgrade me on one of their premium servers that have litespeed since than i can't have a full scan with wordfence and alwayes scan won't compelete
    also i installed wordfence on one of my clients site with litespeed and wordfence won't work on it too.
    this problem on wordpress site because firstly i thinks it is plugin issue:
    http://wordpress.org/support/topic/wordfence-never-completed-on-litespeed
    second problem is wordpress w3 total cache disk enhanced problem with litespeed the problem fully described here:
    http://wordpress.org/support/topic/page-cache-and-disk-enhanced-problem
    and the third problem is with disqus the plugin won't work well with litespeed and can't sync my comment's with disqus

    I am not expert on webserver and don't have any Technical opinion but i think the first and third problem is with the way php execution because in this two cases php not executed well
  2. mistwang

    mistwang LiteSpeed Staff

    Please upgrade to 4.2.11 first

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.11

    If the problem persists, we probably need temp root access to find out what is wrong. Please contact us at bug@litespeed...
  3. amirreza

    amirreza New Member

    sorry for disturbing again
    but the problem with wordfence remained as it is
    i waited about one month to see whether wordfence or litespeed updates fix t he problem but there isn't any fix in their update
    i have wordfence in 2 litespeed host and it doesent work on either of them

    while i like litespeed for many features it has but this problem gets on nerve.
    while i am not expert on web-servers or debugging but i think the problem is on getting IPs
    the error wordfence showed are like this:
    Wordfence can't get the IP of clients and therefore can't operate. We received IP: 10.11.182.233, 92.42.55.36. X-Forwarded-For was: 10.11.182.233, 92.42.55.36 REMOTE_ADDR was: 00.000.000.000 Headers that may contain the client IP: HTTP_X_FORWARDED_FOR => 00.00.100.000, 00.40.50.00 REMOTE_ADDR => 00.00.0.00 SERVER_ADDR => My site ip

    i changed IPs due to security reasons
  4. NiteWave

    NiteWave Administrator

    I have no experience/knowledge regarding wordfence, so it's hard to trouble-shoot it and give any advice.
    can you provide me the access to a wordpress account, to know about what the issue is ?
    amirreza likes this.
  5. amirreza

    amirreza New Member

    thank you NiteWave
    yes i would be glad to get the access you want but please provide me an email address @ litespeed domain
    also my site is on persian but wordfence won't translated an is on english if you need other section of wordpress except wordfence be in english tell me to make the backend lang english

    but i must say that any wordfence on litespeed have the same issue and it is not only my problem
  6. webking_amsterdam

    webking_amsterdam New Member

    Amirreza !


    Also having a problem with Wordfence on a few WordPress sites I have just finished installing ( Free ) Comodo WAF ( web application firewall ) replacing Wordfence as it also offers a better protection than WordFence. More info at: https://waf.comodo.com/ Its ModSecurity rules are also compatible with Litespeed !

    Also having a continuously running ( not stopping ) Wordfence scanner ( and not downloading the files ) looking for a solution I found the following post ( advising to use Comodo WAF ! ):

    http://www.webhostingtalk.com/showthread.php?t=1369769

    http://www.webhostingtalk.com/showpost.php?s=a7d718406d9ae31f1adf392728aeeed8&p=9094791&postcount=4

    I have posted information on Comodo WAF with web links to detailed instructions for installing it:

    http://www.litespeedtech.com/suppor...le-while-parsing-multipart_strict_error.8950/

    Hope this helps !
    Last edited: Jul 5, 2014
    amirreza likes this.
  7. NiteWave

    NiteWave Administrator

    amirreza, first please refer webking_amsterdam's message.
    please use "Start a Conversation" function of this forum, it's better than email to track the progress.
    the conversation is private.
    amirreza likes this.
  8. amirreza

    amirreza New Member

    thanks a lot webking but i don't think i need firewall and also i am on shared hosting with directadmin so i don't think i can installed it
    i use wordfence for scanning and don't need it for firewall as for firewall i use bulletproofsecurity
  9. amirreza

    amirreza New Member

    @NiteWave
    I send the user pass you needed
    would be glad if you can look at it
  10. NiteWave

    NiteWave Administrator

    @amirreza,
    I can login. has replied you there for 2 questions.
  11. amirreza

    amirreza New Member

    Thank you @NiteWave
    now i understand why people use Litespeed
    not only it is a great webserver but also it have a great support

Share This Page