LiteSpeed ignores cache disable

Discussion in 'LiteSpeed Cache' started by jacob, Oct 30, 2013.

  1. jacob

    jacob New Member

    Hi,

    For a domain say: x.com I have disabled the cache in the litespeed webconsole: Configuration->Server->Cache->Do-Not-Cache Domains:

    Code:
    *.a.com,a.com,x.com,*.x.com
    the htaccess file for the domain is also set to:

    Code:
    RewriteRule .* - [E=Cache-Control:no-cache] 
    The cache storage path is set to /lshttpd/diskcache and the folder have been cleared after the above settings have been made to ensure the cache was completely clear.

    Browsers cache/cookies have been cleared.

    Yet on the second load of the webpage I get the following: [​IMG]

    So as you can see the private cache is still being hit and LiteSpeed seems to be ignoring any of the settings both the HTTP headers and the configuration set in the web console.
    Last edited: Oct 30, 2013
  2. NiteWave

    NiteWave Administrator

    it's because you enabled private cache.

    disable it and see:
    lsws admin console->Server->Cache->Enable Private Cache:No
  3. jacob

    jacob New Member

    Yes, yes, that is very true!

    What I want to do is disable the private cache for this specific domain. LiteSpeed should respect the options set as explained above.

    Interestingly enough it does seem to work now which I find a bit odd. Should setting the above settings, clearing the lshttpd diskcache and clearing the browser cache not result in the cache not being used right away?

Share This Page