LSWS 3.0 admin interface problem

Discussion in 'Bug Reports' started by alex, Mar 16, 2007.

  1. alex

    alex New Member

    After upgrading to the 3.0 release version when I try to access the web interface I get the screen for the username and password. After entering those a pop up comes up that says:
    Internet explorer cannot open the Internet site http://xxxxxxxx
    Operation aborted
  2. mistwang

    mistwang LiteSpeed Staff

    Did you upgrade from command line or via the web admin interface?
    There might be something wrong with the later, please try a manual upgrade then restart the server.
  3. garrow

    garrow New Member

    This issue is most likely caused by the use of YUI. Unfortunately a manual reinstall doesn't seem to fix it.

    I googled "IE operation aborted javascript" and found the following about the
    "Operation Aborted" message.

    Chances are you are calling some object's render method before IE has had a chance to build the DOM (of course, every other browser seems to work fine). More annoyingly, this seems to be a race condition, so you might not always catch it.

    http://www.technovelty.org/code/web/yui-rendering.html

    The error is particular to IE6/IE7.
  4. mistwang

    mistwang LiteSpeed Staff

    We found that it relates to the number of tooltips on the page. When there are more than 10 tooltips, we got the error. Will investigate more.
  5. hugemikeyd

    hugemikeyd New Member

    Have you guys figured anything out regarding this? I still see the issue with 3.0.2
  6. mistwang

    mistwang LiteSpeed Staff

    My IE6 on WinXP works well with the admin console.
    Which version of IE are you using?
  7. hugemikeyd

    hugemikeyd New Member

    I have tried IE6 and IE7, it's very intermittent for me. Sometimes i can login and click around for a while and other times i get an alert that pops up with an error. I do not have any issues using Firefox however.

    I am not sure that this matters, but i have compiled my own version of PHP since i need 5.1+ for some apps, but i have followed the same procedure as the version 2 series without issue.

    System info is as follows:

    Server: LiteSpeed/3.0.2 Standard
    OS: Ubuntu Edgy Linux
    Release: 2.6.16.29-xen
    Version: #3 SMP Sun Oct 15 13:15:34 BST 2006
    Machine: x86_64
  8. mistwang

    mistwang LiteSpeed Staff

    It is just a YUI/IE issue on the client side, have nothing to do with your PHP binary. :)

    Please use Firefox for now. we will try upgrading YUI library see if it helps.
  9. hugemikeyd

    hugemikeyd New Member

    Works for me :)
  10. mistwang

    mistwang LiteSpeed Staff

    We updated YUI to the latest release, please give it try see if it helps or not.

Share This Page