LSWS 4.2.0 Bug - No .rtreport files created

Discussion in 'Bug Reports' started by cmanns, Oct 17, 2012.

  1. cmanns

    cmanns New Member

    This seems to be 2cpu server license bug only.

    ^Working VPS with 4.2 (CloudLinux, Xen Cloud platform system CentOS6..)

    Oh wait the system in question is now generating reports, it took an entire day and multiple litespeed restarts but finally .rtreport* files to graph with munin! I'll report back if it's working

    srwxr-xr-x 1 apache apache 0 Oct 16 22:45 lsphp5.sock.22445
    -rw-r--r-- 1 apache apache 1399 Oct 17 15:38 .rtreport
    -rw-r--r-- 1 apache apache 1618 Oct 17 15:38 .rtreport.2
    -rw-r--r-- 1 root apache 1288 Oct 17 15:38 .status


    However the munin graphs (Same plugin, same dir for .rtreport and the graph plugin I'm using works for multi-cpu licenses. It's still not graphing but I'm not sure when it started working.
    Last edited: Oct 17, 2012
  2. cmanns

    cmanns New Member

    Looks like it just took forever to generate those files, now their there, then the litespeed munin graphs are working cept the uh requests one I think but I think thats due to change in your rtereport format. I will post the fix if I figure out why those graphs are blank.

    Thanks for lack of reply. Version 4.2 seems to be a bad upgrade so far, I've done our own cPanel system and a clients DirectAdmin system. 4.2 reports its not the newest version it feels buggy and I'm not sure how much more I trust LiteSpeed.

    I've been told by people I tune their servers amazingly better then the horrible cost they pay you guys, I'm concerned about continuing to use LiteSpeed (and my clients are) with it's price, bugs, issues, and generally Apache and properly setup FastCGI has it been benchmarked? Well I can simply switch to a tuned apache setup and watch graph differences, there's not much on a loaded cPanel system with dozens and dozens of sites switching to Litespeed.

    So that makes me and others wonder why are we paying so much? I'm currently devloping a Web Hosting Panel, OS, and Engine. I guess I should maybe blueprint the designs to a better, free to use apache webserver replacement or is LiteSpeed going to get on their ass and product a product that actually works good as it says. Lots of your listed used clients have switched to other solutions, I and my clients are nearing that too.

    I'll soon be suggesting against LSWS and for other alternatives like using Varnish & Apache, I currently advertise and suggest client's LSWS. The company's incompetence in providing an enterprise webserver (Feels like it should be free it's not much better then apache, it just bitches in logs about normal DirectAdmin or cPanel htaccess lines.

    Anyways hope this is read by proper staff and reacted too. I currently am worrying about continuing to use LiteSpeed with CloudLinux on cPanel systems.
  3. webizen

    webizen New Member

    4.2 is not yet enabled in auto update (usually takes weeks for major release like 4.2 to be enabled). 4.1.13 still the latest in auto update.

    For bugs, send what you found to bug@.
  4. mistwang

    mistwang LiteSpeed Staff

    The rtreport file is located at server level, if you run munin under one user account inside a cage, that user wont be able to access rtreport files. each cage has its own /tmp directory.
  5. cmanns

    cmanns New Member

    I will send that it took over a day for 4.2 2 cpu to create rtreport files.

    thanks.
  6. cmanns

    cmanns New Member

    The system I was mentioning does not run CloudLinux, XenServ does. My 3rd party IT clients don't. Their system is actually DirectAdmin CentOS 6.

    Munin was allowed to see the file, what I was saying was there was NO .rtreport files on the server even after updatedb not a single trace of one.

    Then next day they magically appeared and graphs started working :rolleyes::confused:

Share This Page