Missing gems and log error clairity please

Discussion in 'Ruby/Rails' started by nathanc, Mar 2, 2008.

  1. nathanc

    nathanc New Member

    I am seeing this in the error log. Seems there is a missing gem. However its not telling me which gem is missing.

    I am seeing this alot.

    [LSAPI:STDERR]: SIGUSR1
    [LSAPI:STDERR]: (
    [LSAPI:STDERR]: SignalException
    [LSAPI:STDERR]: )
    [LSAPI:STDERR]: from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    [LSAPI:STDERR]: from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    [LSAPI:STDERR]: from ./config/../vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:495:in `require'
    [LSAPI:STDERR]: from ./config/../vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:342:in `new_constants_in'
    [LSAPI:STDERR]: from ./config/../vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:495:in `require'
    [LSAPI:STDERR]: from /usr/local/lib/ruby/1.8/test/unit/ui/testrunnermediator.rb:8
    [LSAPI:STDERR]: from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    [LSAPI:STDERR]: from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    [LSAPI:STDERR]: ... 11 levels...
    [LSAPI:STDERR]: from /usr/local/lib/ruby/1.8/test/unit/autorunner.rb:199:in `run'
    [LSAPI:STDERR]: from /usr/local/lib/ruby/1.8/test/unit/autorunner.rb:13:in `run'
    [LSAPI:STDERR]: from /usr/local/lib/ruby/1.8/test/unit.rb:278
    [LSAPI:STDERR]: from /opt/lsws/fcgi-bin/RailsRunner.rb:27


    Any ideas?
  2. mistwang

    mistwang LiteSpeed Staff

    check code testrunnermediator.rb:8 ?

Share This Page