My server stopped.

Discussion in 'General' started by Amanda, Nov 5, 2008.

  1. Amanda

    Amanda New Member

    Here are the error messages from the log file:


    2008-11-05 20:55:41.190 [NOTICE] Loading LiteSpeed/3.3.20 Standard ...
    2008-11-05 20:55:41.290 [NOTICE] [ADMIN] server socket: uds://usr/local/lsws/admin/tmp/admin.sock.7756
    2008-11-05 20:55:41.290 [NOTICE] Loading configuration from /usr/local/lsws/conf/httpd_config.xml ...
    2008-11-05 20:55:41.290 [NOTICE] Recovering server socket: [*:80]
    2008-11-05 20:55:41.290 [NOTICE] Recovering server socket: [*:3100]
    2008-11-05 20:55:41.290 [INFO] old priority: 0, new priority: 0
    2008-11-05 20:55:41.290 [INFO] [config:server:basic] For better obscurity, server version number is hidden in the response header.
    2008-11-05 20:55:41.294 [NOTICE] The maximum number of file descriptor limit is set to 1024.
    2008-11-05 20:55:41.298 [NOTICE] [child: 7357] Successfully change current user to www-data
    2008-11-05 20:55:41.298 [NOTICE] [Child: 7357] Core dump is enabled.
    2008-11-05 20:55:41.298 [NOTICE] [Child: 7357] Setup swapping space...
    2008-11-05 20:55:41.298 [NOTICE] [Child: 7357] LiteSpeed/3.3.20 Standard starts successfully!
    2008-11-05 20:55:41.298 [NOTICE] [AutoRestarter] new child process with pid=7357 is forked!
    2008-11-05 20:55:42.102 [NOTICE] [AutoUpdate] Checking for new releases...
    2008-11-05 20:55:42.334 [INFO] [AutoUpdate] No new update.
    2008-11-05 20:56:28.600 [NOTICE] Server Restart Request via Signal...
    2008-11-05 20:56:28.604 [NOTICE] [Child: 7357] Start shutting down gracefully ...
    2008-11-05 20:56:28.604 [INFO] Pass listener *:80.
    2008-11-05 20:56:28.604 [INFO] Pass listener *:3100.
    2008-11-05 20:56:28.604 [NOTICE] [Child: 7357] Shut down successfully!
    2008-11-05 20:56:28.604 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets belong to process 7357 !
    2008-11-05 20:56:28.612 [NOTICE] [AutoRestarter] child process with pid=7357 exited with status=0!
    2008-11-05 20:56:28.612 [NOTICE] [PID:7354] Server Stopped!

    I have no idea how to fix it. Any ideas?
  2. mistwang

    mistwang LiteSpeed Staff

    Try upgrading to 3.3.22
  3. Amanda

    Amanda New Member

    Is this the correct syntax?

    sudo ./update.sh 3.3.22 std linux

    I'm logged in as a sudoer.
  4. mistwang

    mistwang LiteSpeed Staff

    Just login to the web console and click update link.

    Or just run install.sh select upgrade.
  5. Amanda

    Amanda New Member

    Install.sh wants me to do a completely new install.

    I would log into the web console but it doesn't load.
  6. IrPr

    IrPr New Member

    So you have to run install.sh and try to upgrade or reinstall
  7. anewday

    anewday Moderator

    After you run install.sh, did you input the same installation folder you installed it to? It won't let you upgrade if the folder doesn't already exist.

Share This Page