Now another issue.. bah

Discussion in 'Install/Configuration' started by Styles, Jun 19, 2008.

  1. Styles

    Styles New Member

    While trying to get my Apache config, I stoped litespeed and apache took over. Now note, I have cPanel/WHM. I'm trying to use http://www.litespeedtech.com/support/wiki/doku.php?id=litespeed_wiki:apache:cPanel tutorial. Now where it saids set the port, I always get a connection failed or w/e. Its bull. And now, its stuck with apache running and LiteSpeed isnt! help!!

    *Btw I notice a considerable amount of speed lost*
  2. mistwang

    mistwang LiteSpeed Staff

    service httpd stop
    service lsws start
  3. Styles

    Styles New Member

    Thanks! It was so weird like now it works but I get:

    Then once I set the port it breaks more.
  4. mistwang

    mistwang LiteSpeed Staff

    Do you want to use LiteSpeed with Apache together or use LiteSpeed along to replace Apache?
  5. Styles

    Styles New Member

    Ideally I would like them running together. I also followed the tutorial to fix Subdomain indexing. Now, when I create a subdomain, it doesn't work. All it does is create an invisable dir somewhere. I don't know where. In root typing dir you can see it. But in FTP you can't see it. I can create a folder right there.. Its really weird..

    btw I followed this tutorial all the way through too : http://litespeedtech.com/support/wiki/doku.php?id=litespeed_wiki:apache:cpanel
    Last edited: Jun 19, 2008
  6. mistwang

    mistwang LiteSpeed Staff

    If you do not have a compelling reason to use LSWS with Apache together, it is a lot easier to just use LSWS along.

    If you does, you have change Apache listening port to 79, then have LSWS use "Port Offset=1", so LSWS will use port 80 and forward requests back to Apache on Port 79 if need.
  7. Styles

    Styles New Member

    Does Apache hinder lightspeeds performance in any way? Also, how do you change LS's port? I only see Apache.
    Sorry if some questions are dumb.. I've been up for over 24 hours I can't even think straight! lol

    Thanks
  8. mistwang

    mistwang LiteSpeed Staff

    You should take a break. :)

    You can change Apache's listening port with WHM "Tweak settings".

    Running Apache and LSWS at the same time will take more server resource.
  9. Styles

    Styles New Member

    hey .. yeah how do I disable apache then? the subdomain thing.
  10. mistwang

    mistwang LiteSpeed Staff

    service httpd stop

    then change "Apache Port Offset" to "0" in LSWS admin console, restart.
  11. mistwang

    mistwang LiteSpeed Staff

    I don't know what is the problem with subdomain, it should be cPanel/WHM issue, not really related to LSWS. And it should work as expected no matter Apache or LSWS was used. If you create the subdomain under cPanel, then just remove it under cPanel.

Share This Page