PHP compile Debian & Plesk

Discussion in 'Install/Configuration' started by server4vn, Jun 20, 2010.

  1. server4vn

    server4vn New Member

    Hello
    I ve installed Litespeed on my Debian & Plesk Panel server btw i did setup the user and group in the install progress as www-data because there is no apache user and group ( i guess ur guide in wiki page is out dated ? ) . And then when compile PHP i have this error
    checking for specified location of the MySQL UNIX socket... no
    configure: error: Cannot find MySQL header files under yes.
    Note that the MySQL client library is not bundled anymore!
    **ERROR** Could not configure PHP build

    And inside the Litespeed Web admin console i got this error

    Found 2 warning/error messages in the log: More
    Time Level Message
    2010-06-20 03:36:15.937 ERROR [/etc/apache2/apache2.conf:137] Invalid user name: ${APACHE_RUN_USER}!
    2010-06-20 03:36:15.937 ERROR [/etc/apache2/apache2.conf:138] Invalid group name: ${APACHE_RUN_GROUP}!

    Pls help me Thanks so much
  2. mistwang

    mistwang LiteSpeed Staff

    You need to install the "dev" package for mysql, you need to find out the package name of you system. it could be
    libmysqlclient-dev, mysql-dev etc.
  3. mistwang

    mistwang LiteSpeed Staff

    Not sure about the Apache_run_user and Apache_run_group error, does plesk uses mod_macro?
    Mod_macro support is in 4.1RC3 only.
  4. server4vn

    server4vn New Member

    Thanks for quick reply i ve fixed the issue with php compile by install the libmysqlclient-dev ( i did some research myself on google :D ) . For the error
    2010-06-20 03:36:15.937 ERROR [/etc/apache2/apache2.conf:137] Invalid user name: ${APACHE_RUN_USER}!
    2010-06-20 03:36:15.937 ERROR [/etc/apache2/apache2.conf:138] Invalid group name: ${APACHE_RUN_GROUP}!

    i dont know if the problem caused because i set the user and group in Litespeed to www-data ???
  5. mistwang

    mistwang LiteSpeed Staff

    Please post the configuration around line 137 138 of /etc/apache2/apache2.conf. see if it is in a macro or something.
  6. server4vn

    server4vn New Member

    This is line 136 137 138 pls help

    # These need to be set in /etc/apache2/envvars
    User ${APACHE_RUN_USER}
    Group ${APACHE_RUN_GROUP}


    Btw i think maybe because of wrong User/Group setting , when i swich to Litespeed i can not upload image ???? i got this message

    Whenever i swich back to Apache i can upload just fine . With Litespeed music file upload i can still upload no problem =.= so i dont know/understand what is problem here , i can upload music files but not image file =.= ?
  7. mistwang

    mistwang LiteSpeed Staff

    As long as you install LSWS as the same user/group that being set in /etc/apache2/envvars, then it is fine, you can ignore those warnings.

    The second error, maybe due to missing PHP modules or something.
    If you use suphp or PHP suEXEC with Apache, you need to turn on PHP suEXEC in LSWs, otherwise, turn PHP suEXEC off.
  8. server4vn

    server4vn New Member

  9. jahil

    jahil New Member

    nice hint - thanks

Share This Page