PHP Files on one account have error "503 Service Unavailable"

Discussion in 'PHP' started by iUnknown, Nov 9, 2008.

  1. iUnknown

    iUnknown New Member

    Hello,

    As said in the thread title, I have a problem with one hosting account's PHP files. Some of the PHP files are encoded with ioncube, and some are not. All give this error. I have another account with files encoded with ioncube in and they work fine.

    This account works fine with apache though.

    Thanks.
  2. iUnknown

    iUnknown New Member

    I posted this in another thread about another issue I was having, and it relates to this:

  3. mistwang

    mistwang LiteSpeed Staff

    Maybe it is due to file permission issue if you are using PHP suEXEC.
  4. mistwang

    mistwang LiteSpeed Staff

    Run LiteSpeed on another port with port offset, then build matching PHP binary. If Apache does not use "PHP suEXEC", then "build matching PHP binary", then you can try disabling PHP suEXEC from LiteSpeed.
  5. iUnknown

    iUnknown New Member

    This is what I did originally. My apache uses suEXEC and I used the build matching php binary feature. It now won't let me use it again because it's already matching.

    Must I disable suEXEC before doing this litespeed build?

    Thanks

    Edit: Just realised PHP suEXEC and suEXEC are two different things... I believe that I use both... is that a problem?
    Last edited: Nov 10, 2008
  6. mistwang

    mistwang LiteSpeed Staff

    suEXEC is for CGI script, PHP suEXEC is for PHP script.
    If you are using Apache mod_php, then your Apache does not do PHP suEXEC.

    In easy apache, you can enable "suphp" to enable PHP suEXEC.
  7. iUnknown

    iUnknown New Member

    Ok, but how does this affect litespeed's php?
  8. mistwang

    mistwang LiteSpeed Staff

    Apache's PHP wont affect LiteSpeed PHP. those two are independent.
    However, it is a good idea to have Apache and LiteSpeed has similar PHP setup, so you can easily trouble shoot one or another by means of comparison.

    If you need to rebuild matching PHP no matter the configuration is match or not, you can remove lsws/fcgi-bin/lsphp-5.x.x.
  9. iUnknown

    iUnknown New Member

    I used the "build matching PHP binary" function originally to rebuild litespeed's php to what I have for apache... so surely it should be identical? Can litespeed's php not have php suexec or something?
  10. iUnknown

    iUnknown New Member

    Please can someone help me with this because there is no point in me having this product if it isn't working for me...
  11. mistwang

    mistwang LiteSpeed Staff

    Just uninstall LSWS from WHM plugin and start over again.
    There is an option to control PHP suEXEC when you reinstall LSWS form WHM plugin. build matching PHP. Make sure to set the "Port Offset", to something like "2000", and open port 2080 from your CSF firewall to test LSWS before put it in production.
  12. iUnknown

    iUnknown New Member

    So... I should uninstall and install again?

Share This Page