Poblem after switch to litespeed

Discussion in 'General' started by TakCloud, Jul 18, 2012.

  1. TakCloud

    TakCloud New Member

    hi
    im install litespeed on directadmin
    after switch to litespeed all website error unable to connect and not open !!!
  2. webizen

    webizen New Member

    Make sure matching php gets built before switch.
  3. TakCloud

    TakCloud New Member

    i am copmpile php via admin litespeed (7080)
    But there remains the problem
  4. webizen

    webizen New Member

    Make sure the php built via lsws admin console has the same set of extensions that match with apache php.
  5. TakCloud

    TakCloud New Member

    i am compile via admin consol
    is not ok !!!! ;(
  6. webizen

    webizen New Member

    See if lsws is listening on port 80:

  7. TakCloud

    TakCloud New Member

    attached !
    is not ok !:(:(:(:(
    please help me

    Attached Files:

  8. webizen

    webizen New Member

    your LSWS is listening on port 2080. you need to change Apache Port Offset (Admin Console => Configuration => Server => Using Apache Configuration File) to 0 from 2000.
  9. TakCloud

    TakCloud New Member

    ok Thanks is run
    But now after switch litespeed all website open white page
    is not open script!!!
  10. webizen

    webizen New Member

    Make sure you build matching php from Cpanel plugin GUI (whm => plugins => litespeed web server => build matching php).
  11. TakCloud

    TakCloud New Member

    my control panel is directadmin
    how build matching?
    Thanks
  12. webizen

    webizen New Member

  13. TakCloud

    TakCloud New Member

    When I could not get him
    You have to login to the server can do for me?
  14. webizen

    webizen New Member

    will pm you a detailed instruction.
  15. webizen

    webizen New Member

    here is one for general public:

    1. get stock php compile options
    type 'php -i | less' and look for Configure Command like following:
    2. Go through LSWS Admin Console => Actions => Compile PHP with above compile options (note: remove "Configure Command => './configure'")

    3. Once complete, run '/usr/local/lsws/fcgi-bin/lsphp5 -i' to compare with 'php -i' and make sure they match.

Share This Page