Problem loading Gems

Discussion in 'Ruby/Rails' started by Klian, Jul 1, 2008.

  1. Klian

    Klian New Member

    Hi,

    Ive installed LSWS but I cant run my rails projects.

    Ive created a hello world project and I receive a 503 error.

    The stderror.log says:
    ./config/boot.rb:9:in `require': No such file to load -- rubygems (LoadError)

    Ive checked the ruby path and is set correctly: /usr/bin/ruby

    Im using LSWS v3.3.14.

    My projects work fine with Webrick and Thin servers.

    Thanks!! :)
  2. mistwang

    mistwang LiteSpeed Staff

    Maybe you have another ruby installation in /usr/local/bin/ruby or somewhere.
    Try
    "which ruby"
    from your command line.

Share This Page