Problem upgrading to 4.1.7

Discussion in 'Bug Reports' started by anewday, Oct 29, 2011.

  1. anewday

    anewday Moderator

    I attempted an upgrade from 4.1.6 to 4.1.7 via ssh. After doing a graceful restart in the web gui, it still shows running on 4.1.6. I clicked on SwitchTo 4.1.7 but it's still stuck at 4.1.6. Never seen this happen before.

    This is how it looks like on the Version Manager:

    4.1.7 SwitchTo Remove Force Reinstall
    4.1.6 Active Force Reinstall

    Edit: found these entries in the error log.

    #################
    2011-10-28 19:34:34.918 NOTICE [72.89.x.x:55117-0#_AdminVHost] [STDERR] PHP Warning: socket_connect() unable to connect [2]: No such file or directory in /usr/local/lsws/admin/html.4.1.7/classes/ws/Service.php on line 267
    2011-10-28 19:34:34.945 NOTICE [72.89.x.x:55117-0#_AdminVHost] [STDERR] failed to connect to server! socket_connect() failed: No such file or directory
    2011-10-28 19:35:40.893 NOTICE [72.89.x.x:55243-0#_AdminVHost] [STDERR] switchTo
    2011-10-28 19:35:40.893 NOTICE [72.89.x.x:55243-0#_AdminVHost] [STDERR] PHP Warning: socket_connect() unable to connect [2]: No such file or directory in /usr/local/lsws/admin/html.4.1.7/classes/ws/Service.php on line 267
    2011-10-28 19:35:40.893 NOTICE [72.89.x.x:55243-0#_AdminVHost] [STDERR] failed to connect to server! socket_connect() failed: No such file or directory
    Last edited: Oct 29, 2011
  2. webizen

    webizen New Member

    upgrade from ssh (command line) should do a restart. pls verify the file ownership
  3. anewday

    anewday Moderator

    I restarted lsws from command line and now it's showing 4.1.7.

    ls -al /usr/local/lsws/admin/tmp
    total 12
    drwx--x--- 2 lsadm nobody 4096 Oct 28 19:53 ./
    drwxr-xr-x 25 root root 4096 Oct 28 19:34 ../
    srwxr-xr-x 1 lsadm lsadm 0 Oct 28 19:48 admin.sock.7963=
    -rw------- 1 lsadm lsadm 183 Oct 14 16:35 sess_71e8fa15fa6654548f3d15a751a48ad3
  4. webizen

    webizen New Member

    i meant no need to manual restart. upgrade script does restart by itself. error message below indicate there is likely permission issue in /usr/local/lsws/admin/tmp where admin.sock resides which caused php failed to connect.

    usually a force re-install from command line should fix the issue.

Share This Page