Problems with php 5.2.9

Discussion in 'Install/Configuration' started by xinn, Apr 9, 2009.

  1. xinn

    xinn New Member

    I'm having some problems with compiling php 5.2.9 on Centos 5.3 64b.
    I'm receiving this error:

    _object_handlers.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo sapi/litespeed/lsapi_main.lo sapi/litespeed/lsapilib.lo main/internal_functions.lo -lcrypt -lcrypt -lrt -lmysqlclient -lgd -lfreetype -lpng -lz -ljpeg -lcurl -lz -lresolv -lm -ldl -lnsl -lxml2 -lz -lm -lcurl -ldl -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lidn -lssl -lcrypto -lz -lxml2 -lz -lm -lmysqlclient -lz -lcrypt -lnsl -lm -lssl -lcrypto -lxml2 -lz -lm -lcrypt -lxml2 -lz -lm -lxml2 -lz -lm -lxml2 -lz -lm -lcrypt -o sapi/litespeed/php
    libtool: link: warning: library `/usr/lib64/libz.la' was moved.
    libtool: link: warning: library `/usr/lib64/libz.la' was moved.
    /usr/bin/ld: /usr/bin/ld: BFD 2.17.50.0.6-9.el5 20061020 internal error, aborting at ../../bfd/bfd.c line 506 in _bfd_default_error_handler

    /usr/bin/ld: Please report this bug.

    collect2: ld returned 1 exit status
    make: *** [sapi/litespeed/php] Error 1

    Do you have any idea what is wrong?
  2. anewday

    anewday Moderator

    Try:

    chmod 0755 /usr/bin/ld

Share This Page