redirect non latin urls

Discussion in 'General' started by gschultz, Jul 15, 2009.

  1. gschultz

    gschultz New Member

    I want to redirect requests like

    Code:
    www.domain.tld/art%C3%ADculos
    to the ASCII version:

    Code:
    www.domain.tld/articulos
    I tried to resolve the problem by using
    Code:
        <context>
          <type>redirect</type>
          <uri>/art%C3%ADculos</uri>
          <externalRedirect>1</externalRedirect>
          <statusCode>301</statusCode>
          <location>/articulos</location>
          <note></note>
          <allowOverride></allowOverride>
          <realm></realm>
          <authName></authName>
          <required></required>
          <accessControl>
            <allow></allow>
            <deny></deny>
          </accessControl>
          <authorizer></authorizer>
        </context>
    but didn't succeed.

    Suggestions are welcome.
    Last edited: Jul 15, 2009
  2. gschultz

    gschultz New Member

    encoding problem?

    I found that this is working

    <rewrite>
    <enable>1</enable>
    <logLevel>0</logLevel>
    <rules>RewriteRule ^/?art&Atilde;culos/(.*)$ articulos/$1 [R=301,L]</rules>
    </rewrite>

    Is there a problem with LiteSpeed config files encoding?
    Last edited: Jul 16, 2009
  3. mistwang

    mistwang LiteSpeed Staff

    How about directly edit the configuration file? Does it work?
    We do need to improve the multi-language support in LSWS console.

Share This Page