[RESOLVED] Setting up SSI

Discussion in 'Install/Configuration' started by kule, Feb 25, 2010.

  1. kule

    kule New Member

    Probably simple but couldn't see the answer anywhere:

    How do I setup SSI to process .shtml files for say the PHP_SuEXEC virtual host template?

    Thanks
    Luke
    Last edited by a moderator: Feb 26, 2010
  2. kule

    kule New Member

    It's all a bit quiet...is my question that dumb or does nobody know? :)

    I know you used to have to pass over requests to Apache but I'm pretty sure I read that you can now process SSI with version 4.x - that's correct isn't it?
  3. anewday

    anewday Moderator

    Not everyone reads the forum everyday. It has only been 10 hours since you posted.
  4. mistwang

    mistwang LiteSpeed Staff

    set MIME type to application/x-httpd-shtml for that file suffix.
  5. kule

    kule New Member

    @anewday apologies for my perceived lack of patience

    @mistwang thank you again; figured it out from what you said:

    Go to the conf folder of your litespeed installation directory e.g.

    cd /usr/local/lsws/conf

    And edit the mime.properties file and append:

    shtml = application/x-httpd-shtml

    Obviously you may still need to update your virtual host template to include index.shtml files as an index file (from the web admin go to virtual host templates, edit, general, scroll down to 'index files' and edit the 'index files' list).

    Hopefully that's helpful to someone else (or me later)

    Cheers
    Luke

Share This Page