[RESOLVED] signal=9 errors on mutiple litespeed servers

Discussion in 'General' started by nolnet, Feb 15, 2010.

  1. nolnet

    nolnet New Member

    I too am getting multiple signal=9 errors on 3 of my litespeed servers. They are gnerated randomly with no connection to new accounts or server changes, In fact, I even get them on an a new 8 core nehalem server with 3 small little webites.

    At [15/Feb/2010:05:16:16 -0600], web server with pid=834 received unexpected signal=9, no core file is created. A new instance of web server will be started automatically!

    Any help is appreciated.

    Todd
    Last edited by a moderator: Feb 17, 2010
  2. Tony

    Tony Member

    I'm going to guess and say you're running cPanel 11.25? I'm pretty sure it's the cause but I don't know where or why they're trying to do restarts.
  3. mistwang

    mistwang LiteSpeed Staff

    We have changed the "lswsctrl" script a little bit to deal with issue related to cPanel 11.25, it may contribute some of signal=9 error, we updated it again with more conservative method.

    Please either manually download and upgrade 4.0.12 again, or just replace the /pth/to/lsws/bin/lswsctrl script with the one in latest 4.0.12 release.
  4. ffeingol

    ffeingol Member

    @nolnet,

    And if you are running cPanel 11.25, what version of LSWS do you have running and do you still have Apache running?
  5. nolnet

    nolnet New Member

    We're running 4.0.12 LSWS only apache is not running. I'll download and re-install and see what happens.

    Thank you,

    Todd
  6. mistwang

    mistwang LiteSpeed Staff

    Any update? Is it OK now?
  7. nolnet

    nolnet New Member

    Yep that solved it. I only get the signal=9's when new accounts are added.

    Thanks!
  8. tachra

    tachra New Member

    But i am having it in LSWS 4.0.17 and it is awful my cPanel version is cPanel 11.26.20!!!!
    i am getting both signal 9 and signal 15 errors!
  9. mistwang

    mistwang LiteSpeed Staff

    Did it start to happen after cPanel upgrade? or you only use LSWS with cPanel 11.26.20?

Share This Page