[solve] Need Help To Configure LiteSpeed

Discussion in 'General' started by Prince, Mar 11, 2011.

  1. Prince

    Prince New Member

    Please i need help for the right setting in "Server> External App > lsphp5

    My total daily traffic is average 20k, i'm in two dedicated servers one for web pages and the second for db.

    My problem is that my site do crawl during peak while i have enough server resources.


    Server 1 spec
    AMD Quad x 8 CORES 2.0Ghz Opteron 6128 - Total of 32 CORES

    12GB DDR3 SDRAM


    Server 2 spec
    AMD Quad x 8 CORES 2.0Ghz Opteron 6128 - Total of 32 CORES

    8GB DDR3 SDRAM


    I have attached screenshot of my Litespeed values.

    I need help for the right values to increase my site speed.

    Thanks.

    Attached Files:

    Last edited by a moderator: Mar 15, 2011
  2. webizen

    webizen New Member

    Please be more specific of your traffic volume. 20k hits/sec or 20kbps or 20k unique visitors? What kind of site are you running? Without these specifics, it is hard to tell what settings are right for you.

    Run tool like top to see what process takes most system resources, where the bottleneck is during the peak time and go from there.
  3. Prince

    Prince New Member

    It's 20k unique visitors.
  4. webizen

    webizen New Member

    run top for both servers during peak hours and paste result here.
  5. Prince

    Prince New Member

    Where do i find top to run?
    is it in WHM or Litespeed?

    Thanks.
  6. webizen

    webizen New Member

    on command line, type 'top'
  7. NiteWave

    NiteWave Administrator

    Prince, your attachment is too small to view clearly.

    it looks you set
    Max Connections=200
    PHP_LSAPI_CHILDREN=210

    this is wrong, the 2 figures should be equal. you can revert both to the default 35.
  8. Prince

    Prince New Member

    ok, i have set both to 35,

    but is 35 not too small for a site with 1,800 queries per second?

    Thanks.
  9. NiteWave

    NiteWave Administrator

    monitor the performance by real-time stats

    admin console->Actions->Real-Time Stats,
    particularly "EAProc WaitQ" column for your concern.
  10. Prince

    Prince New Member

    What will "EAProc WaitQ" tell me?
  11. Prince

    Prince New Member

    Please my "EAProc WaitQ" is 323 and my site crawl due to it, and it's causing server high load.

    What should i change in litespeed settings?

    Thanks.
    Last edited: Mar 14, 2011
  12. webizen

    webizen New Member

    set Max Connection and PHP_LSAPI_CHILDREN to 50, 100, 150 (increase by 50 at a time) and see if EAProc WaitQ goes down.
  13. Prince

    Prince New Member

    I set it to 150 max and 150 children it has gone down to 0, but i will keep monitoring.

    Thanks.

Share This Page