[solved] 503 Service Unavailable in WHMCS

Discussion in 'General' started by 3245, Jun 7, 2013.

  1. 3245

    3245 Member

    Hello
    when my customer need pay invoice, have following error:
    PHP:
     503 Service Unavailable
    The server is temporarily busy
    , try again laterPowered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible 
    for administration and contents of this web site!
    also when i want go to module sms, i see same error

    PHP:
    [PHP Modules]
    bcmath
    calendar
    Core
    ctype
    curl
    date
    dom
    eAccelerator
    ereg
    filter
    ftp
    gd
    gettext
    hash
    iconv
    imap
    ionCube Loader
    json
    libxml
    mbstring
    mcrypt
    mysql
    openssl
    pcre
    PDO
    pdo_mysql
    pdo_sqlite
    pgsql
    posix
    Please help me.

    Thank you.
    Last edited by a moderator: Jun 9, 2013
  2. NiteWave

    NiteWave Administrator

    see if same issue I experienced yesterday:
    please give the output of:
    /usr/local/lsws/fcgi-bin>./lsphp5 -i > ttt
  3. 3245

    3245 Member

    hello
    it is
    root@Host [~]# /usr/local/lsws/fcgi-bin>./lsphp5 -i > ttt
    -bash: /usr/local/lsws/fcgi-bin: No such file or directory

    Note: i use CloudLinux
    Note2: when switch to apache, have not problem, but in litespeed have this problem.
  4. NiteWave

    NiteWave Administrator

    should be
    root@Host [~]# /usr/local/lsws/fcgi-bin/lsphp5 -i > ttt
  5. 3245

    3245 Member

    out is :

    My server is very secur with Team security.

    PHP:
    root@Host [~]# /opt/lsws/fcgi-bin/lsphp5 -i > ttt
    /opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    /
    opt/lsws/fcgi-bin/lsphp5: /usr/lib64/libxml2.so.2no version information available (required by /opt/lsws/fcgi                                         -bin/lsphp5)
    lsphp5symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20090626/pdo_sqlite.soundefined sy                                         mbolsqlite3_libversion
  6. NiteWave

    NiteWave Administrator

    almost same issue I experienced :)

    You've not built matching php successfully.

    Please do it and see what prevent you to complete it.

    tip: which php.ini is used?
    /opt/lsws/fcgi-bin/lsphp5 -i|grep "Loaded Configuration File"

    assume it's /usr/local/lib/php.ini
    edit it, comment out
    extension=pdo_sqlite.so

    it'll resolve the issue
  7. 3245

    3245 Member

    Hello, thank you for your helping
    i see it:
    but again do it
    i change extension=pdo_sqlite.so to ;extension=pdo_sqlite.so

    and now out is:
    still i have problem.
  8. NiteWave

    NiteWave Administrator

    can you switch to apache, delete or rename /opt/lsws/fcgi-bin/lsphp5(maybe plus /opt/lsws/fcgi-bin/lsphp-5.3.24), then build matching php ?
  9. 3245

    3245 Member

    i do rename all lsphp with version and without version to mmXXXmm and do rebuild php matching:
    - it is possible we disable Litespeed for one domain?
    but still is problem
    have you any idea?

    Thank you.
    Last edited: Jun 7, 2013
  10. webizen

    webizen New Member

  11. 3245

    3245 Member

    now i run: mv /opt/xml2 /opt/xml2.bak
    then run rebuild Easyphp
    then run match php LSWS
    then run
    then run
    but also have problem

    Have you any idea?

    thank you.
  12. NiteWave

    NiteWave Administrator

    how about output of
    # php -i > ttt
    ? and
    # /opt/lsws/lsphp5/bin/php -i > ttt
    ?
  13. 3245

    3245 Member

    out:
    and
    out:
    and
    out:
  14. 3245

    3245 Member

    again change extension=pdo_sqlite.so to ;extension=pdo_sqlite.so
    now out:
    then delete all lsphp
    then repuild match php, but still have problem
    Last edited: Jun 8, 2013
  15. NiteWave

    NiteWave Administrator

    the primary issue is because easyApache haven't built php 5.2.4 successfully:
    so Build Matching PHP for lsphp5 also failed.

    if easyApache succeed,matching lsphp5 will succeed as well.
  16. 3245

    3245 Member

    Please wait, i speak with Cpanel.
  17. 3245

    3245 Member

    This problem was solved with the help CPanel staff and litespeed staff,
    soloution:

    then see it work fine:

  18. NiteWave

    NiteWave Administrator

    thanks for the info, surely will benefit others.

    is /usr/lib/libxml2.so.2 32-bit or 64-bit ?
  19. 3245

    3245 Member

    Your welcome
    my OS is centos - 64bit - cpanel
    i have CloudLinux + LiteSpeed + Cpanel
  20. 3245

    3245 Member

    1-have you latest version from litespeed?
    2- Have you latest version from cloudlinux?
    3- do you read and run all content in this post's?

Share This Page