[solved] Bind to IP: 0.0.0.0

Discussion in 'Install/Configuration' started by katana123, Aug 23, 2011.

  1. katana123

    katana123 New Member

    Hello,

    All of port 80 and port 443 are binding to every IP addresses that we have on the server which created very long list when we do netstat.

    How do i bind them to 0.0.0.0:80 & 0.0.0.0:443
    so it won't create the very long list like apache does.

    Thank you.
    Last edited by a moderator: Aug 24, 2011
  2. mistwang

    mistwang LiteSpeed Staff

    Just create listener in native configuration from LSWS web console. listen to
    *:80 , *:443
  3. katana123

    katana123 New Member

    On web console, I go to Configuration > Listeners

    I created: Any port 80 non-SSL and Any port 443 SSL.

    restart the lsws from the SSH.

    They are still listening to all of IP that we have.
  4. mistwang

    mistwang LiteSpeed Staff

    You need a full stop then start from command line.
    ./lswsctrl stop
    ./lswsctrl start
  5. katana123

    katana123 New Member

    The port 80 is binding on ANY IP now.
    However, the port 443 is still listening to all of the IP.

    The way i set them up on the Web admin Listener General Setting:
    IP Address: ANY
    Port: 443
    Binding: Not Set
    Secure: Yes

    For the Secure, do i need to put in "Yes" since port 443 is for SSL?
    If i set it up to YES, it will not bind to ANY IP port 443
  6. mistwang

    mistwang LiteSpeed Staff

    You need to set the default SSL key/cert for listener 443.
  7. katana123

    katana123 New Member

Share This Page