[Solved] Domlogs not generated

Discussion in 'General' started by JorgeC, Jan 17, 2011.

  1. JorgeC

    JorgeC New Member

    For some reason LSWS is not generating domlogs, I was looking all over the setting and I can't find an option that may be check on where this are disabled. If I switch to Apache everything works fine.

    At "Configuration" --> Server --> log is set

    Access Log: $SERVER_ROOT/logs/access.log
    Piped Logger: No Set
    Log Format: No Set
    Rolling Size (bytes): 2000 M
    Keep Days: 30
    Compress Archive: Yes

    With this setting in other servers domlogs are being generated without any problem, but not on one server. I'm not sure if there's any setting that I may be missing (Server run Whm/Cpanel)
  2. webizen

    webizen New Member

    What are the version of LSWS and cPanel/WHM?
  3. JorgeC

    JorgeC New Member

    4.0.18 Ent (x86_64)
    WHM 11.28.64
    CLOUDLINUX 5.5 (OS)
  4. mistwang

    mistwang LiteSpeed Staff

    Have you checked the permission of /usr/local/apache/domlogs/, and the log file? "nobody" user should have write permissions. "chmod/chown" may fix this.
  5. JorgeC

    JorgeC New Member

    Yes, besides that when I switch to Apache the logs are generated without any problem. The issue only arise when I use litespeed.
  6. mistwang

    mistwang LiteSpeed Staff

    Apache create the log file with "root" user and keep the file open, there wont be any permission problem.

    LSWS create those log files on demand with "nobody" user, you need to do the one time fix of the permission when LSWS is used.
  7. JorgeC

    JorgeC New Member

    Permision and ownership of the folder is perfect, I tried recreating the whole domlogs folder, when I restart litespeed domlogs files are recreated, but not populated with any data.
  8. mistwang

    mistwang LiteSpeed Staff

    can you give output of

    ls -ld /usr/local/apache/domlogs
    ls -l /usr/local/apache/domlogs/<one domain access log file>

    send PM if you think the data is sensitive.
  9. JorgeC

    JorgeC New Member

    ls -ld /usr/local/apache/domlogs
    drwxr-xr-x 250 root wheel 155648 Jan 17 23:42 /usr/local/apache/domlogs/


    ls -l /usr/local/apache/domlogs/domain.com
    -rw-r--r-- 1 nobody username 0 Jan 17 21:13 /usr/local/apache/domlogs/domain.com
    Last edited by a moderator: Jan 18, 2011
  10. mistwang

    mistwang LiteSpeed Staff

    It is fine.
    Looks like we need to take a look at the server, please contact support@litespeed
  11. JorgeC

    JorgeC New Member

    Done, thanks :)
  12. webizen

    webizen New Member

    The issue is resolved after force reinstall 4.0.18.
  13. JorgeC

    JorgeC New Member

    Yes, thank you very much.

Share This Page