[Solved] Fatal Error

Discussion in 'Install/Configuration' started by speedingsoft, Jul 1, 2011.

  1. speedingsoft

    speedingsoft New Member

    Fatal error: Call to undefined function mysql_connect()

    Doesn't happen with Apache.

    Im probably missing something obvious, anyone care to point it out. :)
  2. NiteWave

    NiteWave Administrator

  3. speedingsoft

    speedingsoft New Member

    From researching it seems i need --with-mysql


    However when I try to compile php I get this:
    =============================================
    Compile PHP with LSAPI

    fail to save current configuration.

    Fail to generate build script, please try to manually fix the error first.
    Failed to create manual install script: /usr/local/lsws/phpbuild/buildphp_manual_run.sh
    ==============================================
  4. speedingsoft

    speedingsoft New Member

    Having no luck with this...
  5. mistwang

    mistwang LiteSpeed Staff

    You may change some permission manually under /usr/local/lsws, the default should work fine. Please do a reinstall.
    Make sure there are enough disk space available under /usr/local/lsws.
  6. speedingsoft

    speedingsoft New Member

    lsws is 755, and Ive tried reinstalling several times already.

    I will try 777 I guess and reinstall.
  7. speedingsoft

    speedingsoft New Member

    Little farther.

    Now Im getting configure: error: libpng.(a|so) not found.
    **ERROR** Could not configure PHP build
  8. mistwang

    mistwang LiteSpeed Staff

  9. speedingsoft

    speedingsoft New Member

    Added in:
    --with-jpeg-dir=/usr/lib64


    it went about 10 lines farter in the compling process but still comes back.
    =========
    checking for the location of libjpeg... /usr/lib64
    checking for the location of libpng... no
    checking for the location of libXpm... no
    checking for FreeType 2... no
    checking for T1lib support... no
    checking whether to enable truetype string function in GD... no
    checking whether to enable JIS-mapped Japanese font support in GD... no
    checking for fabsf... yes
    checking for floorf... yes
    configure: error: libjpeg.(a|so) not found.
    **ERROR** Could not configure PHP build
    =========
    Also:
    Package libjpeg-devel-6b-37.x86_64 already installed and latest version
    libjpeg is there at /usr/lib64
    ===
    I even tried:
    --with-jpeg-dir=/usr/lib64/libjpeg.so
    Last edited: Jul 1, 2011
  10. mistwang

    mistwang LiteSpeed Staff

    have you add "--libdir=lib64"?
    Just use "--with-jpeg-dir=/usr".
  11. speedingsoft

    speedingsoft New Member

    Here is what I have:

    --with-libdir-dir=/usr/lib64 --with-jpeg-dir=/usr/lib64 --with-png-dir=/usr/lib64 --with-mysql --with-mysqli --with-zlib --with-gd --enable-shmop --enable-track-vars --enable-sockets --enable-sysvsem --enable-sysvshm --enable-magic-quotes --enable-mbstring --with-iconv
    Last edited: Jul 1, 2011
  12. speedingsoft

    speedingsoft New Member

    Just tried that, still getting:

    configure: error: libjpeg.(a|so) not found.
    **ERROR** Could not configure PHP build
  13. mistwang

    mistwang LiteSpeed Staff

    should be "--with-libdir=lib64".
  14. speedingsoft

    speedingsoft New Member

    That make any difference, however, i copied both libjepg.so & libpng.so into /usr/lib from /usr/lib64

    And I am now compiling PHP, x'ing my fingers....

    Edit: And it works!
    Last edited: Jul 1, 2011

Share This Page