[Solved] Forwarding vhosts

Discussion in 'General' started by ToddFreeman, Oct 23, 2012.

  1. ToddFreeman

    ToddFreeman New Member

    We are using litepeed load balancer to loadbalance a cpanel cluster, however currently it does not seem to forward the vhost information, it just forwards the traffic to the IP.

    So when we have multiple domains on the same IP, we only get the "default" page, it does not display the vhosts that was requested. Also for this setup apache is running on port 82, LSLB is on port 80.
    The node address line is this:
    (lb02)68.235.35.001>68.235.35.002:82, (lb02)68.235.35.001->68.235.35.003:82

    [where 001 is the LB 002 is node1 and 003 is node2 ]
  2. webizen

    webizen New Member

    check domains of vhost mappings in listener. make sure '*' or domain name is there.
    make sure vhost is enabled on the cpanel.
  3. ToddFreeman

    ToddFreeman New Member

    Yes I have verified all of that, also the sites are working normally without the load balancer, they only start displaying the default page when going through LSLB.
    Adding a * means it would be passing no vhost information to the webserver.
  4. webizen

    webizen New Member


    try followings:
    1. change node list to 68.235.35.001->68.235.35.002:82, 68.235.35.001->68.235.35.003:82
    or
    2. create two workgroups (instead of one) with one node address per each.


    BTW, our lab test confirms '*' in listener enables lslb pass through received vhost name to the backend (as pointed out earlier).
    Last edited: Oct 25, 2012
  5. ToddFreeman

    ToddFreeman New Member

    Thank you, changing the node line and splitting it into 2 workers did the trick.

Share This Page