[solved] High CPU Usage

Discussion in 'Install/Configuration' started by sirjuninho, May 31, 2014.

  1. sirjuninho

    sirjuninho New Member

    [​IMG]

    [​IMG]

    There is anything I can do to reduce this CPU usage?

    Thanks!
  2. sirjuninho

    sirjuninho New Member

    I made some changes and it's better now.

    PHP suEXEC -> Yes
    PHP suEXEC Max Conn -> 100
    Smart Keep-Alive -> No
    Run On Start Up -> suEXEC Daemon

    There's anything else I can do to reduce CPU usage?
  3. NiteWave

    NiteWave Administrator

    build one of opcode cache: xcache or Zend opcache, should reduce the load
  4. sirjuninho

    sirjuninho New Member

    [​IMG]

    [​IMG]

    Is it correct?
  5. sirjuninho

    sirjuninho New Member

    I think I got it. Is it right now?

    [​IMG]


    [xcache]
    ; ini only settings, all the values here is default unless explained

    ; select low level shm/allocator scheme implemenation
    xcache.shm_scheme = "mmap"
    ; to disable: xcache.size=0
    ; to enable : xcache.size=64M etc (any size > 0) and your system mmap allows
    xcache.size = 64M
    ; set to cpu count (cat /proc/cpuinfo |grep -c processor)
    xcache.count = 2
    ; just a hash hints, you can always store count(items) > slots
    xcache.slots = 8k
    ; ttl of the cache item, 0=forever
    xcache.ttl = 0
    ; interval of gc scanning expired items, 0=no scan, other values is in seconds
    xcache.gc_interval = 0

    ; same as aboves but for variable cache
    xcache.var_size = 0M
    xcache.var_count = 1
    xcache.var_slots = 8K
    ; default ttl
    xcache.var_ttl = 0
    xcache.var_maxttl = 0
    xcache.var_gc_interval = 300

    xcache.test = Off
    ; N/A for /dev/zero
    xcache.readonly_protection = Off
    ; for *nix, xcache.mmap_path is a file path, not directory.
    ; Use something like "/tmp/xcache" if you want to turn on ReadonlyProtection
    ; 2 group of php won't share the same /tmp/xcache

    ; leave it blank(disabled) or "/tmp/phpcore/"
    ; make sure it's writable by php (without checking open_basedir)
    xcache.coredump_directory = ""

    ; per request settings
    xcache.cacher = On
    xcache.stat = On
    xcache.optimizer = On

    [xcache.coverager]
    ; per request settings
    ; enable coverage data collecting for xcache.coveragedump_directory and xcache_$
    xcache.coverager = Off

    ; ini only settings
    ; make sure it's readable (care open_basedir) by coverage viewer script
    ; requires xcache.coverager=On
    xcache.coveragedump_directory = ""
  6. NiteWave

    NiteWave Administrator

    yes --- the 1st screenshot of phpinfo, shows "Opcode Cache:disabled"
    the 2nd screenshot of phpinfo, shows "Opcode Cache:enabled, ..."

    does the load of lsphp5 get dropped ?
  7. sirjuninho

    sirjuninho New Member

    Yes, it did.

    [​IMG]

    Thanks again NiteWave!
  8. NiteWave

    NiteWave Administrator

    yes, reduced significantly --- this clearly shows the power of opcode cache (plus litespeed's unique suEXEC Daemon mode)
  9. sirjuninho

    sirjuninho New Member

    The only thing killing me now is MySQL haha, I will need to optimize the queries direct on the script I think...

    Anyway, it's better now! :)

Share This Page