[solved] Keeping Apache really dead (not mostly dead)

Discussion in 'General' started by theRKF, Mar 17, 2013.

  1. theRKF

    theRKF Member

    We have a recurring problem where Apache keeps getting set to start on boot. This leads to a conflict between httpd and lsws whenever the server is rebooted.

    We've used chkconfig to set httpd to "off", and even gone so far as to chmod /etc/init.d/httpd to 000.

    I think the problem is that cPanel's scripts keep reviving Apache during their auto-upgrades.

    I know this isn't specifically a LiteSpeed issue, but since everyone here has opted for LiteSpeed over Apache it's probably that someone has had to deal with this before, right?
    Last edited by a moderator: Mar 19, 2013
  2. webizen

    webizen New Member

    You do not chkconfig httpd to 'off'. Instead, you still need it to be on.

    What you should do is set below in LSWS Admin Console (Configuration => Server => General => Using Apache Configuration File)
  3. theRKF

    theRKF Member

    Ok, thank you. I still had Auto Reload set to the deprecated (yes) option that was set when the LiteSpeed team first installed LSWS. Never changed it.

    I've changed to your suggested settings and restarted LSWS.

    The problem I'm trying to combat is that when the server starts up Apache starts serving sites instead of LiteSpeed, so I have to killall Apache and restart LSWS to get sites functioning properly.

    Is there another setting I'm missing?
  4. webizen

    webizen New Member

    Upon you changed to the suggested settings, a wrapper script should be created and replace apache binary. you can run following command to check. It should show it a script text instead of ELF executable. The actual Apache binary should be renamed to /usr/local/apache/bin/httpd_ls_bak.
    Use WHM plugin gui to switch to LSWS and then you should be ok ('service httpd restart' will bring up lsws instead of apache).
  5. theRKF

    theRKF Member

Share This Page