[Solved] Litespeed 4.0.18 swap too fast after start

Discussion in 'Install/Configuration' started by DoM, Dec 14, 2010.

  1. DoM

    DoM New Member

    Hi,
    i use litespeed on other webservers and everything works well.

    On this server, everything works with apache but when i START litespeed (even on port 2080), server start eat ram like chips.

    In around 1-2 seconds litespeed procs take about 6GB RAM and server start swap.

    I use version 4.0.18 on this server

    On other servers i use 4.0.17

    Maybe a bug version ?

    Also i notice that no log are saved to /usr/local/apache/logs/access_log on this server while on all other servers everything is logged good.



    Waiting for your reply


    Regards
  2. DoM

    DoM New Member

    I checked better and i notice that after a restart (graceful) old MAIN proc and subprocesses of litespeed will not be killed:

    ps auxwwf |grep -i lite
    root 8208 0.0 0.0 61140 740 pts/3 D+ 18:20 0:00 \_ grep -i lite
    root 1778 16.2 11.2 942448 915560 ? S< 18:18 0:12 litespeed (lshttpd)
    nobody 1836 0.3 11.1 942312 915444 ? S< 18:19 0:00 \_ litespeed (lshttpd)
    nobody 1837 0.1 11.1 942224 915308 ? S< 18:19 0:00 \_ litespeed (lshttpd)
    nobody 1838 24.7 11.2 946244 919528 ? D< 18:19 0:16 \_ litespeed (lshttpd)
    nobody 1839 0.3 11.1 942312 915412 ? S< 18:19 0:00 \_ litespeed (lshttpd)
    nobody 1841 0.5 11.2 942320 915504 ? S< 18:19 0:00 \_ litespeed (lshttpd)
    nobody 1843 0.2 11.1 942224 915308 ? S< 18:19 0:00 \_ litespeed (lshttpd)
    nobody 1848 1.2 11.2 942312 915492 ? S< 18:19 0:00 \_ litespeed (lshttpd)
    nobody 1850 0.2 11.1 942224 915308 ? S< 18:19 0:00 \_ litespeed (lshttpd)

    After a graceful restart:

    ps auxwwf |grep -i lite
    root 1778 3.4 3.9 942448 320260 ? S< 18:18 0:13 litespeed (lshttpd)
    nobody 1836 1.6 9.3 942312 764808 ? D< 18:19 0:06 \_ litespeed (lshttpd)
    nobody 1838 17.8 4.7 952840 391648 ? D< 18:19 1:07 \_ litespeed (lshttpd)
    nobody 1839 1.4 8.7 942312 715900 ? D< 18:19 0:05 \_ litespeed (lshttpd)
    nobody 1841 1.7 9.8 942320 803388 ? D< 18:19 0:06 \_ litespeed (lshttpd)
    nobody 1843 1.4 8.9 942224 734316 ? D< 18:19 0:05 \_ litespeed (lshttpd)
    nobody 1848 1.7 9.2 942312 756960 ? D< 18:19 0:06 \_ litespeed (lshttpd)
    nobody 1850 1.4 8.9 942224 728368 ? D< 18:19 0:05 \_ litespeed (lshttpd)
    root 9752 13.1 4.7 943904 390644 ? S< 18:23 0:12 litespeed (lshttpd)
    nobody 9930 0.6 4.7 943768 392104 ? S< 18:24 0:00 \_ litespeed (lshttpd)
    nobody 9931 0.2 4.8 943680 393328 ? S< 18:24 0:00 \_ litespeed (lshttpd)
    nobody 9932 10.0 4.9 944720 402088 ? D< 18:24 0:07 \_ litespeed (lshttpd)
    nobody 9934 0.2 4.8 943768 393532 ? D< 18:24 0:00 \_ litespeed (lshttpd)
    nobody 9935 1.2 4.8 943880 394492 ? S< 18:24 0:01 \_ litespeed (lshttpd)
    nobody 9936 0.2 4.7 943680 391592 ? S< 18:24 0:00 \_ litespeed (lshttpd)
    nobody 9937 0.2 4.7 943680 391988 ? S< 18:24 0:00 \_ litespeed (lshttpd)
    nobody 9938 0.2 4.8 943680 393444 ? S< 18:24 0:00 \_ litespeed (lshttpd)
    root 9951 0.0 4.7 943904 390188 ? DN 18:24 0:00 \_ litespeed (lshttpd)


    Waiting for your reply

    Regards
  3. webizen

    webizen New Member

    Regarding kill old processes, you can adjust Graceful Restart Timeout parameter (Console->Configuration->Server->General->Server Process-Graceful Restart Timeout) to see any difference. The default is 300 seconds.
  4. DoM

    DoM New Member

    No way. It does not work if i set that value to 0 or to 1.

    Litespeed still do not kill old procs.


    Waiting for your reply

    Regards
  5. DoM

    DoM New Member

    So there are 2 problems with 4.0.18 and cPanel:

    1) on admin console value "Server Process-Graceful Restart Timeout" is ignored and litespeed procs are not killed

    2) Nothing is logged on access_log


    I notice also that on ALL other litespeed web servers version still 4.0.17 and there is no advise or automatic update to 4.0.18 ( also no entry in update.log )

    Maybe if i downgrade this server from 4.0.18 to 4.0.17 it will work ?


    Waiting for your reply

    Regards
  6. webizen

    webizen New Member

    1. autoupdate for 4.0.18 is not yet turned on.
    2. do you have anything logged in error.log or stderr.log?
    3. you may downgrade to 4.0.17 and see if that makes difference. otherwise, pm me the server temporary access for further investigation.
  7. DoM

    DoM New Member

    I want try to downgrade right now.

    How can i do this on cPanel and where can i find 4.0.17 version?


    Waiting for your reply

    Regards
  8. mistwang

    mistwang LiteSpeed Staff

    You can try our 4.1RC4 build, it should reduce the memory usage dramatically.

    http://www.litespeedtech.com/packages/4.0/lsws-4.1RC4-ent-x86_64-linux.tar.gz
    i386 package is available as well.
  9. webizen

    webizen New Member

  10. DoM

    DoM New Member

    I will try both.

    Do you know when 4.1 will be stable ?


    Waiting for your reply

    Regards
  11. mistwang

    mistwang LiteSpeed Staff

    This issue should be addressed with updated 4.0.18 build.
  12. webizen

    webizen New Member

    4.1 release is shooting for the end of this month (year) if things go smoothly.
  13. DoM

    DoM New Member

    Hi,
    with 4.1 everything works better than 4.0

    Thank you very much

    Regards
  14. mistwang

    mistwang LiteSpeed Staff

    How much memory used by LSWS 4.1 release? How many accounts hosted on that server? Want to know how much memory 4.1 saves.
  15. DoM

    DoM New Member

    Sorry for delay.

    About 512-1024MB difference of memory but anyway no more problem about memory leak on litespeed restart.

    On that server were hosted about 3000 cPanel accounts with remote MySQL.


    Best regards

Share This Page