[solved] litespeed requires 777 permission

Discussion in 'Install/Configuration' started by noooy, Mar 13, 2012.

  1. noooy

    noooy New Member

    Hello
    I installed litespeed on a directadmin server ,previously the server run suphp ,so there's no need to change some files or folders to 777 , all the files are 644 and folders are 755 ,but after switch to litespeed, I have to change some folders and files to 777 ,then they are writeable, I search a lot ,but got nothing ,I have to look for help from you ,
    how to configure litespeed settings, then I can use litespeed the same as suphp on files or folders permission settings ,only 644 and 755 ,thanks.
    Last edited by a moderator: Mar 19, 2012
  2. noooy

    noooy New Member

  3. webizen

    webizen New Member

    please provide example for your issue (files with 777 permission instead of 755 work with litespeed) and also check error log (e.g. /usr/local/lsws/logs/error.log) for any details when you have the files set at 755.
  4. noooy

    noooy New Member

    Hello
    I think it's the ownership caused , not the permissions.
    litespeed run as apache:apache,

    ls -l /home
    drwx--x--x 7 libcom access 4096 Mar 18 10:37 libcom

    ls -l /home/libcom/domains/lib.com/public_html
    drwxr-xr-x 11 libcom libcom 4096 Mar 18 10:44 data
    -rw-r--r-- 1 libcom libcom 1096 Dec 21 12:57 connect.php
    -rw-r--r-- 1 libcom libcom 5517 Dec 21 12:57 index.php
    -rw-r--r-- 1 libcom libcom 956 Dec 21 12:57 member.php
    -rw-r--r-- 1 libcom libcom 1355 Dec 21 12:57 misc.php
    -rw-r--r-- 1 libcom libcom 582 Dec 21 12:57 robots.txt
    -rw-r--r-- 1 libcom libcom 1192 Dec 21 12:57 search.php

    can you tell me how to fix the problem ,thanks.
  5. noooy

    noooy New Member

  6. NiteWave

    NiteWave Administrator

    so php suExec is not enabled due to vhost template setting. Thanks for the update. mod_ruid2 not recognized in current lsws version. may recognize it later.

Share This Page