[solved] Problem + litespeed + cpanel + .htaccess + permission

Discussion in 'Install/Configuration' started by pooyan, Jan 20, 2011.

  1. pooyan

    pooyan New Member

    Hello,

    i installed litespeed trial version, now wordpress and joomla! cms not working good,
    .htaccess and permission in two cms not working good,

    for example when installing module in joomla display: * Warning! Failed to move file.
    Last edited by a moderator: Jan 30, 2011
  2. webizen

    webizen New Member

    You should get full function during the trial period.

    As for .htaccess, you need to enable Options or All in HTAccess (LSWS admin console -> Configurations -> Server -> General -> HTAccess).

    Please paste the error message here if persists.
  3. pooyan

    pooyan New Member

    1-
    i attached ht.jpg for HTAccess, can you please check it?

    2-
    i attached l.jpg and l1.jpg, some times when loin to litespeed panel display this error,

    3- All CMS in server not working good, for example in joomla installer, when Switched to apache joomla installing end good, but wgen Switched to litespeed joomla installing not end good, because installer can't create configuration.php file

    Attached Files:

    • l.jpg
      l.jpg
      File size:
      92.7 KB
      Views:
      6
    • l1.jpg
      l1.jpg
      File size:
      50.7 KB
      Views:
      6
    • ht.jpg
      ht.jpg
      File size:
      54 KB
      Views:
      6
  4. webizen

    webizen New Member

    1. HTAccess settings are correct.

    2. l1.jpg indicates some issue with your rewrite rule (../mn-search.cgi?q=$***&blog_id=1...). $*** should be sth like $1 ($ must be followed by a digit).

    3. Did you enable PHP suEXEC (LSWS admin console -> Configurations -> Server -> General -> Load Apache Configuration File -> PHP suEXEC -> Yes)? That's required in shared hosting environment. It may also fix the permission in l1.jpg.

    BTW, build matching php in case you have not done so. It is also a requirement.
  5. pooyan

    pooyan New Member

    I set LSWS admin console -> Configurations -> Server -> General -> Load Apache Configuration File -> PHP suEXEC -> Yes
    and build matching php

    But problem not fixed, can you please help me?
    Do you want to login to the server to send you check?


    Regards
  6. mistwang

    mistwang LiteSpeed Staff

    Are you using suphp with Apache or mod_php?
    If you do not use suphp, set "PHP suEXEC" to "No".
    Maybe you can try a reinstall from within WHM plugin.
  7. pooyan

    pooyan New Member

    Maybe my server managment reinstall litespeed
    What is the solution?
  8. pooyan

    pooyan New Member

    Hello,

    root@server [/home/userhost/public_html]# tail -f /usr/local/apache/logs/error_log | grep userhost
    2011-01-27 11:34:27.913 [INFO] [HTAccess] Updating configuration from [/home/userhost/public_html/.htaccess]
    2011-01-27 11:34:32.596 [INFO] [HTAccess] Updating configuration from [/home/userhost/public_html/.htaccess]
    2011-01-27 11:34:32.596 [INFO] [114.143.29.237:11329-0#APVH_sample.com] Found symbolic link, or owner of symbolic link and link target does not match for path [/home/userhost/public_html/wp-comments-post.php], access denied.
    2011-01-27 11:34:32.597 [INFO] [114.143.29.237:11329-0#APVH_sample.com] File not found [/home/userhost/public_html/403.shtml]


    Can you please help me?
  9. NiteWave

    NiteWave Administrator

    please run following commands and paste the output:
    #ls -ald /home/userhost
    #ls -ald /home/userhost/public_html
    #ls -ald /home/userhost/public_html/wp-comments-post.php
  10. pooyan

    pooyan New Member


    Here is the output :

    root@server14 [/home/userhost/public_html]# ls -ald /home/userhost
    drwx--x--x 12 userhost userhost 4096 Jan 27 10:10 /home/userhost/
    root@server14 [/home/userhost/public_html]# ls -ald /home/userhost/public_html
    drwxr-x--- 8 userhost nobody 4096 Jan 27 11:39 /home/userhost/public_html/
    root@server14 [/home/userhost/public_html]# ls -ald /home/userhost/public_html/wp-comments-post.php
    -rw-r--r-- 1 userhost userhost 3926 Jan 24 19:28 /home/userhost/public_html/wp-comments-post.php
  11. NiteWave

    NiteWave Administrator

    try:
    #chown userhost:usehost /home/userhost/public_html
  12. pooyan

    pooyan New Member

    I've done what they've told to do. And now its showing 404 Not found and error logs shows :
    =============================================================
    2011-01-27 13:25:28.666 [ERROR] [HTAccess] Failed to open [/home/userhost/public_html/.htaccess]: Permission denied
    2011-01-27 13:25:28.667 [ERROR] [HTAccess] Failed to open [/home/userhost/public_html/.htaccess]: Permission denied
    2011-01-27 13:25:28.667 [INFO] [89.165.81.17:4567-0#APVH_sample.com] File not found [/home/userhost/public_html/index.php]
    2011-01-27 13:25:28.667 [INFO] [89.165.81.17:4567-0#APVH_sample.com] File not found [/home/userhost/public_html/404.shtml]
    =============================================================
  13. NiteWave

    NiteWave Administrator

    looks like your php running as nobody. to confirm this:
    #ps -ef|grep php

    and please post /home/userhost/public_html/.htaccess here.
  14. pooyan

    pooyan New Member



    ==================================
    root@server14 [/home/userhost/public_html]# ps -ef|grep php
    parsinfo 3197 25277 11 13:57 ? 00:00:09 lsphp5
    kocholo 3199 25278 7 13:57 ? 00:00:06 lsphp5
    shiadost 3203 25278 2 13:57 ? 00:00:01 lsphp5
    shiahaco 3214 25278 8 13:57 ? 00:00:04 lsphp5
    kocholo 3228 25278 8 13:57 ? 00:00:03 lsphp5:/home/kocholo/public_html/modules.php
    parsinfo 3241 25277 5 13:57 ? 00:00:01 lsphp5
    shiahaco 3447 25278 10 13:58 ? 00:00:02 lsphp5:/home/shiahaco/public_html/index.php
    filmsaz7 3451 25278 1 13:58 ? 00:00:00 lsphp5
    dehkadey 3452 25278 7 13:58 ? 00:00:01 lsphp5
    buxbazco 3453 25278 0 13:58 ? 00:00:00 lsphp5
    urpatogh 3456 25278 6 13:58 ? 00:00:01 lsphp5
    urpatogh 3457 25278 1 13:58 ? 00:00:00 lsphp5
    urpatogh 3460 25278 7 13:58 ? 00:00:01 lsphp5
    acrofull 3461 25278 3 13:58 ? 00:00:00 lsphp5
    modir 3474 25278 2 13:58 ? 00:00:00 lsphp5
    birdesig 3490 25278 4 13:58 ? 00:00:00 lsphp5
    nanopark 3492 25278 0 13:58 ? 00:00:00 lsphp5
    root 3506 26811 0 13:58 pts/1 00:00:00 grep php
    modir 27212 25278 0 13:24 ? 00:00:04 lsphp5:/home/modir/public_html/live/server.php
    ==================================

    root@server14 [/home/userhost/public_html]# cat .htaccess
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    Options +SymLinksIfOwnerMatch
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    RewriteCond %{HTTP_HOST} ^sampledomain.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www.sampledomain.com$
    RewriteRule ^/?$ "http\:\/\/www\.sample\.com" [R=301,L]
    ==================================
  15. pooyan

    pooyan New Member

    What is the solution?
    Now site display directory list, index file not working
  16. pooyan

    pooyan New Member

    Hello,

    My problem is not any response?
    You do not know the answer?


    regards
  17. NiteWave

    NiteWave Administrator

    Please PM me your site's root access.
  18. pooyan

    pooyan New Member

    I Sent,


    regards
  19. NiteWave

    NiteWave Administrator

    this issue is
    Code:
    2011-01-27 11:34:32.596 [INFO] [114.143.29.237:11329-0#APVH_sample.com] Found symbolic link, or owner of symbolic link and link target does not match for path [/home/userhost/public_html/wp-comments-post.php], access denied.
    wordpress's comment function not working at all.

    the deny actually from mod_security rule. after disable mod_security temporarily, the error was gone.

    We've noticed this special case and working on it for final, ideal solution.
  20. pooyan

    pooyan New Member

    Hello, Thank you,

    I waiting for your answer,

    Regards

Share This Page