[solved] Second domain - 404 not found

Discussion in 'General' started by nikoc1337, Mar 10, 2013.

  1. nikoc1337

    nikoc1337 New Member

    Hey guys. I decided to add a second domain on my server, i configured a new vhost and a new vhost template, also added the domain to the listener.
    But i'am getting a 404 error not found when i visit the domain. On the LSWS Adm console there is not any error.
    Could it be some permission issue?
    Last edited by a moderator: Mar 12, 2013
  2. webizen

    webizen New Member

    Not likely. Permission issue will show 403 error instead of 404. check /usr/local/lsws/logs/error.log from command line for more error context.
  3. nikoc1337

    nikoc1337 New Member

    Ok so just checked it out

    Code:
    013-03-11 01:47:20.204 [ERROR] [HTAccess] Failed to open [/home/mydomain/public_html/.htaccess]: Permission denied
    2013-03-11 01:47:20.204 [INFO] [****:38750-0#mydomain] File not found [/home/mydomain/public_html/]
    2013-03-11 01:47:20.204 [INFO] [****4:38750-0#mydomain] Cannot found appropriate handler for [/]
    
    .htaccess is owned by the user the domain is added to. and the folder /hoem/mydomain/public_html exists.
  4. webizen

    webizen New Member

    maybe hoem is a typo in your previous post. but point out just in case.

    pls check their permission and ownership:
    Last edited: Mar 11, 2013
  5. nikoc1337

    nikoc1337 New Member

    Code:
    drwx------ 6 mydomain mydomain 4096 Mar 11 01:30 /home/mydomain
    drwxr-xr-x 2 mydomain mydomain 4096 Mar 10 23:13 /home/mydomain/public_html
    -rw-r--r-- 1 mydomain mydomain 0 Mar 10 22:38 /home/mydomain/public_html/.htaccess
    
    Edit: Resolved. I did chmod 755 /home/mydomain and it's all cool :D

    Thanks for the help!
    Last edited: Mar 11, 2013
  6. webizen

    webizen New Member

    Thanks for the update. 711 for /home/mydomain should be good enough. or for better security, 710 for /home/mydomain with group owned by nobody (web server user).

Share This Page