[solved] Your PHP installation appears to be missing the MySQL extension

Discussion in 'General' started by tedy, Nov 28, 2012.

  1. tedy

    tedy New Member

    Hi,

    I have read all topic on this and other forums related to this topic, but still didn't find solution for me.

    When I've installed litespeed and configured php I've received this message when visited site on wordpress:

    Your PHP installation appears to be missing the MySQL extension which is required by WordPress.


    After 100x+ recompiling, I'm getting "Error establishing a database connection" now.

    Let me tell that this only happens with litespeed. If I shut it down and run apache - websites work with no problem.

    I'm running CentOS 6.3 64bit on VPS.


    Thank you for support.
    Last edited by a moderator: Nov 29, 2012
  2. NiteWave

    NiteWave Administrator

    what's your php version and php build options ?
  3. tedy

    tedy New Member

    PHP 5.4.8 (litespeed) (built: Nov 28 2012 12:38:36)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies


    '--prefix=/usr/local/lsws/lsphp5' '--with-mysqli' '--with-zlib' '--with-gd' '--enable-shmop' '--enable-track-vars' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-magic-quotes' '--enable-mbstring' '--with-iconv' '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--with-kerberos' '--enable-ucd-snmp-hack' '--enable-shmop' '--enable-calendar' '--without-sqlite' '--with-libxml-dir=/usr' '--enable-xml' '--with-system-tzdata' '--with-mysql=/var/lib/mysql/' '--without-gd' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter' '--without-sqlite3' '--disable-phar' '--disable-fileinfo' '--disable-json' '--without-pspell' '--disable-wddx' '--without-curl' '--disable-posix' '--disable-sysvmsg' '--disable-sysvshm' '--disable-sysvsem' '--with-litespeed' '--with-libdir=lib64' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd'
  4. webizen

    webizen New Member

  5. tedy

    tedy New Member

    It works!

    Looks like I have added too many options during search on forums.

    Thank you very much for support!

Share This Page