Some newbie questions

Discussion in 'Install/Configuration' started by ggendel, Nov 29, 2006.

  1. ggendel

    ggendel New Member

    I've just started trying out litespeed 2.2.6 to replace my apache installation on OpenSolaris x86, but I ran into some silly problems that I'm sure are operator errors. ;)

    First, webdav... It seems that the GET works fine, but the PUT fails with a bad method error. I can't find the magic incantation to allow the PUT.

    Second, .htaccess... I can't get it to authorize. It just lets me into these directories without signon. I believe I have it configured properly.

    Third, access logs... I don't get any. :confused:

    And a note... When I installed it, the install process didn't set the owner-group on the top directory (/usr/local/lsws) so the web configurator couldn't update the xml files, but it also didn't give me any errors, it just didn't do it.

    Thanks,
    Gary
  2. xing

    xing LiteSpeed Staff

    .htaccess must be enabled under the Server -> General page or Vhost -> General page. Make sure you check/enable the .htaccess overrides.

    If you are not getting access logs, are you getting error.log files? Check the litespeed server log file /lswsinstall/logs/error.log to see what messages are there that might point to your configuration fault.

    As for PUT error, are you getting the bad method error in the form of a litespeed formatted error? What is the error message exactly?

    Make sure you have a created an user just for litespeed such as lsws and use that for your installation to avoid any problems. We'll also check on our end to see if the installer script has chown issues under OpenSolaris.
  3. ggendel

    ggendel New Member

    Xing,

    Thanks for the quick response. I have both all ht access enabled, all overrides set and .htaccess set in the Server->General Page and both Vhost->General pages. None of this helped.

    I'm getting error log files, but no errors (other than Ruby not enabled):
    -----------------------------------------------------------------
    2006-11-29 20:49:32.337 [NOTICE] Loading LiteSpeed/2.2.6 Standard ...
    2006-11-29 20:49:32.340 [NOTICE] [ADMIN] server socket: 127.0.0.1:7786
    2006-11-29 20:49:32.340 [NOTICE] Loading configuration from /usr/local/lsws/conf/httpd_config.xml ...
    2006-11-29 20:49:32.342 [INFO] old priority: 0, new priority: 0
    2006-11-29 20:49:32.342 [INFO] [config:server:basic] For better obscurity, server version number is hidden in the response header.
    2006-11-29 20:49:32.349 [NOTICE] The maximum number of file descriptor limit is set to 65536.
    2006-11-29 20:49:32.350 [WARN] [config:server:rails] Cannot find ruby interpreter, Rails easy configuration is turned off
    2006-11-29 20:49:32.351 [INFO] [config:vhost:ApacheMain:logging] no separate logging set up.
    2006-11-29 20:49:32.351 [INFO] [config:vhost:www.genashor.com:443:logging] no separate logging set up.
    2006-11-29 20:49:32.352 [NOTICE] [AutoRestarter] new child process with pid=9830 is forked!
    2006-11-29 20:49:32.353 [NOTICE] [child: 9830] Successfully change current user to webservd
    2006-11-29 20:49:32.353 [NOTICE] [Child: 9830] Setup swapping space...
    2006-11-29 20:49:32.353 [NOTICE] [Child: 9830] LiteSpeed/2.2.6 Standard starts successfully!
    2006-11-29 20:49:33.116 [NOTICE] [AutoUpdate] Checking for new releases...
    2006-11-29 20:49:36.729 [INFO] [AutoUpdate] No new update.
    -----------------------------------------------------------------

    For the PUT error, this is what I get back from the server to my WebDAV client:

    405: This method is not allowed (405).

    Since I don't get anything in the error.log, I can't give you more. Sorry.

    Gary

  4. ggendel

    ggendel New Member

    Xing,

    I have the access log working. I needed to change the Virtual Host access log settings to the server log. The webDAV line is:

    ["www.genashor.com:443"] 192.168.1.130 - - [29/Nov/2006:21:07:16 -0500] "PUT /webdav/gary/xbel.xml HTTP/1.1" 405 384 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0"

    Nothing in the error log though.

    Gary
  5. mistwang

    mistwang LiteSpeed Staff

    Currently, webDAV is not supported by LiteSpeed itself, you need to have LiteSpeed proxy to a webDAV capable backend, like Apache or other server.

Share This Page